Main Content

La traducción de esta página está obsoleta. Haga clic aquí para ver la última versión en inglés.

Impresión de gráficas

Impresión de figuras: Introducción

Es posible imprimir una figura de MATLAB® directamente en una impresora conectada al PC o, también, exportar la figura a uno de los formatos de archivos gráficos estándar que admite MATLAB. Existen dos formas de imprimir y exportar figuras:

  • Utilice la opciones de interfaz gráfica Print, Print Preview o Export Setup en el menú File.

  • Utilice el comando print para imprimir o exportar la figura desde la línea de comandos.

El comando print proporciona un mayor control sobre los drivers y los distintos formatos de archivos. El cuadro de diálogo Print Preview (Vista previa de impresión) brinda mayor control sobre el tamaño de la figura, las proporciones, la ubicación en la página y los encabezados de página.

Impresión desde el menú Archivo

Existen dos opciones en el menú File que se relacionan con la impresión:

  • La opción Print Preview muestra un cuadro de diálogo desde el cual puede visualizar, ordenar y diseñar figuras para su impresión, y desde donde puede imprimir la figura. Esta alternativa incluye opciones que anteriormente formaban parte del cuadro de diálogo Page Setup (Configuración de página).

  • La opción Print muestra un cuadro de diálogo que le permite escoger una impresora, seleccionar opciones estándar de impresión e imprimir la figura.

Use Print Preview para determinar si la salida impresa es la que desea. Haga clic en el cuadro de diálogo Help de Print Preview (Vista previa de impresión) para visualizar información sobre cómo configurar la página.

Exportación de la figura a un archivo gráfico

La opción Export Setup del menú File abre una interfaz gráfica (GUI) que le permite establecer características gráficas, como tamaño de texto, fuente y estilo, para guardar figuras como archivos gráficos. El cuadro de diálogo permite definir y aplicar plantillas para personalizar y estandarizar la salida. Después de la configuración, puede exportar la figura a varios formatos de archivos gráficos, como EPS, PNG y TIFF.

Uso del comando de impresión

El comando print ofrece mayor flexibilidad en lo que respecta al tipo de salida que se envía a la impresora, a la vez que permite controlar la impresión desde archivos de funciones y scripts. El resultado se puede enviar directamente a la impresora predeterminada o se puede almacenar en un archivo de salida especificado. Existe una amplia variedad de formatos de salida disponibles, entre los que podemos mencionar los archivos TIFF, JPEG y PNG.

Por ejemplo, esta instrucción guarda el contenido de la ventana de la figura actual como gráfico PNG en el archivo llamado magicsquare.png.

print -dpng magicsquare.png

Para guardar la figura conservando el mismo tamaño de la figura en la pantalla, use estas instrucciones:

set(gcf,'PaperPositionMode','auto')
print -dpng -r0 magicsquare.png

Para guardar la misma figura como archivo TIFF con una resolución de 200 dpi, use el siguiente comando:

print -dtiff -r200 magicsquare.tiff

Si escribe print en la línea de comandos

print

la figura actual se imprime en la impresora predeterminada.