Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Requisitos de sistema y configuración

Compatibilidad con versionesPython

Para llamar a los módulos, debe tener una versión compatible de la implementación de referencia (CPython) instalada en el sistema. es compatible con las siguientes versiones:Python®MATLAB®MATLAB

  • Versión 2,7

  • Versión 3,5

  • Versión 3,6

  • Versión 3,7

Para determinar si el sistema tiene una versión compatible, utilice la función.pyversion El valor establecido por es persistente en todas las sesiones.pyversionMATLAB

No se puede alternar entre las versiones de una sola sesión. selecciona y carga automáticamente una versión cuando se escribe un comando, por ejemplo:PythonMATLABMATLABPythonPython

py.funcname

Si desea cambiar las versiones, reinicie y ejecute con la nueva información de la versión.MATLABpyversion

Establezca version en PlatformPythonWindows

En las plataformas, utilice cualquiera:Windows®

pyversion version

O

pyversion executable

Nota

Si descargó un intérprete, pero no lo registró en el registro, utilice:PythonWindows

pyversion executable

Establecer versión enPython Mac y plataformasLinux

Para establecer la versión, escriba:

pyversion executable

Dónde executable es la ruta de acceso completa al archivo ejecutable.Python

Descargue la versión de 64 bits de en plataformasPythonWindows

La arquitectura de debe coincidir con la arquitectura de.PythonMATLAB En el sitio web de descarga, las descargas para plataformas son versiones de 32 bits de forma predeterminada.PythonMicrosoft®Windows Para descargar la versión de 64 bits, elija las opciones con el nombre "instalador MSI de Windows x86-64".

Requisitos para compilar ejecutablePython

On yLinux® Mac sistemas, Si compila el ejecutable, configure la compilación con la opción.Python--enable-shared

Consulte también

Sitios web externos