Borrar filtros
Borrar filtros

MATLAB R2023a: Model missing parameters after calling open_system

4 visualizaciones (últimos 30 días)
Brad
Brad el 3 de Abr. de 2023
Comentada: Daniel el 3 de Abr. de 2023
I am currently in the midst of upgrading a matlb project to support R2023a which generates/displays a simulink model and am noticing that, after I have saved and reopened the model that I am missing several of the parameters which I have set using set_param. Is this a known issue with R2023a, or has something changed with open_system/save_system that I am unaware of (as the same pairing works correctly in all previous releases of MATLAB that I have tested it with).
  3 comentarios
Brad
Brad el 3 de Abr. de 2023
Hi Daniel,
The parameters in question are all CustomProperties, which don't appear to be loading after calling open_system. Unfortunately, I don't have a specific block for you.
Daniel
Daniel el 3 de Abr. de 2023
There's not much anyone can do without detail. If there's a file or set of files that you can share which replicates the issue, that would be a good starting point. It's also a lot easier to guarantee that smaller examples are free of sensitive information, if that's a concern.

Iniciar sesión para comentar.

Respuestas (0)

Categorías

Más información sobre Simulink Functions en Help Center y File Exchange.

Productos


Versión

R2023a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by