File Exchange

image thumbnail

HDL Coder Support Package for Xilinx Zynq Platform

Generate code for the FPGA portion of the Zynq-7000 SoC.

45 Downloads

Updated 11 Sep 2019

HDL Coder™ Support Package for Xilinx®Zynq®-7000 Platform supports the generation of IP cores that can be integrated into FPGA designs using Xilinx Vivado® or Xilinx ISE. When used in combination with Embedded Coder® Support Package for Xilinx Zynq-7000 Platform, this solution can program the Xilinx Zynq SoC using C and HDL code generation. The hardware/software codesign workflow spans simulation, prototyping, verification, and implementation.

This support package is functional for R2013a and beyond.

Comments and Ratings (21)

has anyone else has an issue where the Zeboard wont show up in simulink after a few sessions of running simulink? i have been having to uninstall and reinstall the support package to get the zedboard to show again in hdl workflow Step 1 setting target device.

Jack Erickson

For support of targeting specific boards, please contact your local applications engineer to discuss your specific use case and options

I am unable to find Xilinx Zynq ZCU111 Evaluation board in the list of boards available..

ali kucur

solved. try to install from different network or isp. it is very interesting that this add-on is successfully installed on 2019a but 2018a.

ali kucur

i manage to install on 2019a but can't on 2018a.

XIan Huang

2018b无法下载

Eric Cigan

can't download on 2018b.

shalu vijay

When trying to install it is showing the file folder must be in zip format

bokai shi

it is very good

ali kucur

can't download on 2018b.

PILLI RAGHU

Cant download even without firewall and in admin mode (whih matlab answer sheet

following error comes

The following error was detected while downloading hardwaresupportpkgs/targets/hdlcoder_zynq7000_common_1505503132.zip:

Connection reset

Try running MATLAB as administrator before come here and downloading.

ERROR while downloading

error downloading...won't install

error downloading. wont install

Xiao Fu

连接错误
应用程序无法连接到 MathWorks。有关解决此问题的详细信息,请参阅此 支持文章。

Cui YQ

salah

MATLAB Release Compatibility
Created with R2014a
Compatible with R2014a to R2019b
Platform Compatibility
Windows macOS Linux