Main Content

Troubleshooting Connected I/O

Description

Simulink timer is very slow while running Connected I/O simulation.

Action

This is due to presence of blocks with very less sample times. There is a two-way communication between Simulink and the Autopilot while running Connected I/O simulation. This introduces an inherent time overhead for a particular block execution. To resolve the issue, set the sample time of blocks to more than the block execution time for connected I/O simulation. For example, if there are two blocks and block execution time is 20 milliseconds for a block. Then set the minimum sample time of the model as 20*2 = 40 milliseconds. For PX4 Host target this minimum block Execution time is around 10-20 ms and for PX4 hardware boards it is around 20-30 ms.

Troubleshooting Connected I/O with PX4 Host Target

Description

If the system you are using is running slow, following error might appear while starting Connected I/O simulation. This is because PX4 host target and jMAVSim takes more time to launch.

Action

To resolve the issue:

  • Wait till PX4 host target and jMAVSim is launched properly.

  • Start connected I/O simulation again by clicking Run on Modeling tab.

Description

With PX4 v1.10 update, some uORB messages stops updating after an hour. This issue might occur with Connected I/O simulation also.

Action

To resolve the issue:

  • Stop simulation and close PX4 Host Target window.

  • Start connected I/O simulation again by clicking Run on Modeling tab.