Unable to build Gazebo Co-Sim plugin on Ubuntu 22.04 (Jammy) machine with Gazebo 11

25 views (last 30 days)
Hi,
I am using Gazebo 11.10.02, CMake 3.22.1 on my Ubuntu 22.04 (Jammy) machine and MATLAB 2022a in my Windows 11 machine. The problem is that when trying to follow Gazebo Co-Sim tutorial, the plugin build process remains incomplete and throws following errors,
Can anyone provide me steps to resolve this isssue?
Thanks

Accepted Answer

Gaurav Bhosale
Gaurav Bhosale on 1 Sep 2022
Edited: Gaurav Bhosale on 1 Sep 2022
Hi,
The Gazebo Co-Sim plugin is tested and supported for Ubuntu Focal (20.04) + Gazebo 11 as well as supported Ubuntu versions listed in the Gazebo Release Schedule for Gazebo 9, 10 and 11.
As Gazebo 11 is officially supporting upto Ubuntu Focal (20.04), the Gazebo Co-Sim plugin support is limited to same. Further, you can install Gazebo 11 on Ubuntu Jammy (22.04) but the installation process is bit different. Further, most of libraries from Gazebo installation in Ubuntu Jammy (22.04), needs -std=c++17 flag in build process with CMake.
Thus, to overcome this issue, you need to use attached CMakeLists.txt and follow below steps;
  1. Download attached CMakeLists.txt
  2. Copy and replace CMakeLists.txt from GazeboPlugin folder ( where buildPlugin.sh resides ). In your case, the location can be /home/user/src/GazeboPlugin
  3. cd /home/user/src/GazeboPlugin/build
  4. cmake ..
Check that, you should see following message, ( Using flag -std=c++17 )
If you get error in finding c++17 then try to install with this tutorial.
5. make
WIth this change, you are able to build Gazebo Co-Sim Plugin on Ubuntu Jammy (22.04) + Gazebo 11 machine.
Thanks

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by