Attempting to deploy Simulink Model to Arduino returns 'First input can not be empty.' error

4 visualizaciones (últimos 30 días)
Hi,
Im a simulink beginner having some trouble with Simulink, Arduino, and the Simulink Support Package for Arduino Hardware.
To teach myself I'm simply trying to control two pins on the arduino to rotate a DC motor with an encoder.
However when attempting 'Build, Deploy, and Start' i recieve the error:
The following error occurred during deployment to your hardware board: First input can not be empty. Expected a non-empty character vector or a valid file-id.
Im not sure what is causing this issue, and in testing I have tried deploying other basic models and I recieve the same error. It seems I may not have my model setup correctly but I cannot find anything online.
EDIT :
After contacting Mathworks and working together to debug the issue it turns out it is a kind of memory incompatability with windows 11. The support team erased a few lines to overwrite the error as a temporary fix that is working perfectly for me now.
  2 comentarios
Arun Kumar
Arun Kumar el 4 de Oct. de 2022
This looks like an installation issue.
Please reinstall the support package and try again.
Lachlan Downie
Lachlan Downie el 11 de Oct. de 2022
Thank you however I have tried this with no luck. I have also tried updating to the latest version of matlab R2022b and reinstalling the package still with no success.

Iniciar sesión para comentar.

Respuestas (0)

Categorías

Más información sobre Modeling en Help Center y File Exchange.

Productos


Versión

R2022a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by