Borrar filtros
Borrar filtros

QGroundControl doesn't recognize Pixhawk 6x

23 visualizaciones (últimos 30 días)
Carmen
Carmen el 1 de Mzo. de 2023
Respondida: Ankur Bose el 14 de Jul. de 2023
Hi, i have an issue with my pixhawk 6x. When Simulink automatically launches QGroundControl, the board is not recognized and it results disconnected. I’m using a UDP connection. Does somebody know how to fix the problem?
  6 comentarios
Arun Mathamkode
Arun Mathamkode el 17 de Mzo. de 2023
Which QGC version you are using ? Whether this issue is there only when the QGC is automatically lanched from Simulink or you are seeing this when you manually lanch QGC as well?
Carmen
Carmen el 17 de Mzo. de 2023
@Arun Mathamkode We are using the current version (4.2.4.0) and we have the issue only when QGC is automatically launched from Simulink. In the other hand, when we open manually QGC, if the option "Pixhawk" is set in the General tab of the setting menu the board is recognized. Actually, we thought that the problem could be the OS (windows 10 is working with Pixhawk 2.1 Cube, while window 11 seems not to be compatible), but with Pixhawk 6x we have the same issue as always.

Iniciar sesión para comentar.

Respuestas (1)

Ankur Bose
Ankur Bose el 14 de Jul. de 2023
In HITL mode, the Pixhawk 6x is not supposed to connect directly to QGroundcontrol but via the MAVLink bridge in the Simulink plant. Hence, in QGC you need to deselect the Pixhawk checkbox and enable only UDP. To get the QGC connected to Pixawk 6x, just run the Simulink plant and it should bridge the MAVLink data between QGC and Pixhawk 6x

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by