Unable to generate code for STM32

55 views (last 30 days)
abhijeetb89
abhijeetb89 on 6 Jun 2015
Edited: smrtkai on 4 Dec 2015
Hello,
I am trying to generate code for STM32F4 Discovery. I have installed Windows SDK 7.1 and .NET framework 4.0. Using "mex -setup" and "xpcsetCC setup", toolchain "Microsoft Visual C++ 2010" is also configurator but still the code generator gives error -
"An installed compiler was not detected. Certain simulation modes, as well as host-based coder builds require that a compiler be installed. Please install one of the supported compilers for this release as listed at: http://www.mathworks.com/support/compilers/R2015a/win64.html"
One more thing I have observed is that there is no option in "Code Generation" to select toolchain.Please see the image below.
Could you please suggest a solution?
Thanks,
Abhijeet
  8 Comments
abhijeetb89
abhijeetb89 on 29 Jul 2015
Hi Rhys,
could you please paste a snapshot of "Configuration Parameters --> Code Generation". I would like to see the settings.
Thanks.
Abhijeet

Sign in to comment.

Answers (6)

Pascal REYNAUD
Pascal REYNAUD on 8 Jun 2015
Hello,
toolchain is selected from STM32CubeMx tool that must be installed to use STM32-MAT/Target solution.
STM32CubeMx installation path is selected from "STM32 Options" that appears when you select STM32.tlc.
It is used to configure MCU (Pinout and peripherals) and used toolchain.
Then, it is called from Simulink to generate project.
Best regards
Pascal
  4 Comments
Etheric-Dreams
Etheric-Dreams on 25 Jul 2015
Same problem here, any further update?

Sign in to comment.


jonatan blom
jonatan blom on 28 Jul 2015
I’m also getting this error, I can compile my model with 2013b but when I try with 2015a I get the same error as you "An installed compiler was not detected". I have no problem compiling a c file with mex command in the matlab prompt...

yi zhang
yi zhang on 29 Jul 2015
"args.mexOpts = rtwprivate('getMexCompilerInfo','manufacturer','LCC');"-->"args.mexOpts = rtwprivate('getMexCompilerInfo','LCC');" in setup_for_lcc.m. It works in this scenario but the side-effects are unknown yet.

abhijeetb89
abhijeetb89 on 29 Jul 2015
Edited: abhijeetb89 on 29 Jul 2015
Hello Pascal,
Could you do me a favor? If you can generate code at your end, could you please paste a snapshot of "Configuration Parameters ----> Code Generation". I would like to see the settings.
Thanks.
Abhijeet

Valmir Sadiku
Valmir Sadiku on 8 Oct 2015
I have basically the same issues by generating the code for the STM32 : An installed compiler was not detected...
If I check for installed compilers via mex -setup:
MEX configured to use 'Microsoft Windows SDK 7.1 (C)' for C language compilation.
Everything looks fine, building code for Arduino works just fine. What could be the reason for this issue? I have a OS Win7 64-Bit with Matlab 2015b.
I'm thankful for any help or assistance.
Regards,
goldenEyes

smrtkai
smrtkai on 4 Dec 2015
Edited: smrtkai on 4 Dec 2015
I had similiar issues. Maybe these links can help:
I wrote a step by step guide for myself on "How to setup STM32-MAT/TARGET with MATLAB R2015a". https://my.st.com/b476312a
Discussion on st.com:
The STM32-MAT/TARGET was developed for MATLAB R2014a. I was not able to get it working with MATLAB R2015b (generates erroneous). On my system it only works with MATLAB R2015a. I still have trouble to get Processor-In-the-Loop working.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by