Borrar filtros
Borrar filtros

Need help troubleshooting error with Simulink Arduino tutorial related to time-response identification of RC circuit.

6 visualizaciones (últimos 30 días)
I'm working on control systems tutorials found here. I've gone through the majority of the tutorial without issue, however if I try to run the both blocks highlighted, I get a very strange error (attached). If I run either the orange highlighted block, or the blue highlight block by itself, I have no errors, and get the expected output. It's just both together that I'm having issues with.
Does anyone have experience with this? If so, how can I fix the problem?
  1 comentario
Raghul
Raghul el 3 de Oct. de 2017
Sir when i try to simulate the same tutorial in that website. I experienced this problem. Please suggest me to overcome this problem

Iniciar sesión para comentar.

Respuesta aceptada

Hari Desanur
Hari Desanur el 12 de Dic. de 2016
Try to build your Simulink model by using one of the following solvers instead of the default "ode3 (Bogacki-Shampine)" solver -
1. ode8 (Dormand-Prince RK8(7))
2. ode5 (Dormand-Prince)
3. ode2 (Heun)
4. ode1 (Euler)
This should fix the issue. You can change the solver by opening the Configuration Parameters (Ctrl+E) and then changing the 'Solver' under the 'Solver options' menu.

Más respuestas (0)

Categorías

Más información sobre Arduino Hardware en Help Center y File Exchange.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by