VideoReader is unable to read properties and frames

11 views (last 30 days)
Hi everyone,
I have been using VideoReader() for a while, but have run into some issues after updating to Ubuntu 20.04. It seems that it isn't able to load any of the video properties, or the frames, anymore.
Reading a file with:
vid = VideoReader('The_Present.mp4');
I just get something like this:
General Properties:
Name: 'The_Present.mp4'
Path: '/media/max/RedPassport/ECoGData/Tobii/video_files'
Duration: 258.6010
CurrentTime: 258.6010
NumFrames: 0
Video Properties:
Width: 0
Height: 0
FrameRate: 0
BitsPerPixel: 0
VideoFormat: ''
Reading a frame with
results in
'No more frames available to read from file.'
When I loaded the same file on Ubuntu 18.04 I had no issues.
I suspect it is some issue with reading the codec. However, changing the codes on the movie file isn't an option as I need to preserve the information as is.
I tried to update gstreamer, but that didn't help.
I would apprechiate any help on this!
  1 Comment
Adam Danz
Adam Danz on 31 Jul 2021
I'm also having this problem with R2021a Update 4 / Windows 10. But sometimes it works.
It's frustrating.

Sign in to comment.

Accepted Answer

Maximilian Nentwich
Maximilian Nentwich on 8 Feb 2021
Updating Matlab from 2020a to 2020b solved this issue.

More Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by