Borrar filtros
Borrar filtros

[UNSOLVED, but ignored] Simulink model with red border and outlinks

132 visualizaciones (últimos 30 días)
Patrik el 13 de Feb. de 2014
Editada: Gabriele Gualandi el 13 de Mayo de 2019
Dear Forum,
I built a Simulink model and from a certain point, where I don't exactly remember my commitment to that, one subsystem is framed by a red line and the background turned yellow. Please see screenshot attached. Because of data policy I had to pixelate some parts...
There is literally nothing displayed that reveals anything of the cause for that. Taking a look inside of that subsystem, there is everything as usual with respect to the colors. As I seem to be the first one in this company having that problem, noone other knew a solution, nor I was able to find a solution using searching machines.
Despite the simulation still runs, I would be extraordinarily glad to get rid of that suspicious red box. Any help is appreciated!
Best regards, Patrik
  1 comentario
Joe el 7 de Jul. de 2016
I have this same issue. The code inside the box that has a red border and yellow fill does not execute. This happened seemingly randomly on some of my library links. Deleting the block and taking it from the library again solved the issue, but I still do not know why it turned red.

Iniciar sesión para comentar.

Respuestas (5)

Tucker McClure
Tucker McClure el 7 de Oct. de 2016
I've seen blocks get "stuck" like this several times after errors. If you right-click on the block and select Format, you'll likely see that the foreground and background colors are set. I just change them back to black and white (or whatever I'm using).
  1 comentario
Dehan Luan
Dehan Luan el 6 de Dic. de 2018
Hi. It is like what you said. The background and foreground color are set by the tool, then I changed it to white and black respectively. It is wierd I feel!

Iniciar sesión para comentar.

Muruganandham Subramanian
Muruganandham Subramanian el 20 de Feb. de 2014
There are many sources of error/ warning in your model, am just listing something
1. the error may be due to input signal/data length or data type or handling the data inside the subsytem may be the the problem
2.It may be of data dependency error
3. Enabling some warnings/errors setting in configuration parameter settings

Gabriele Gualandi
Gabriele Gualandi el 13 de Mayo de 2019
Editada: Gabriele Gualandi el 13 de Mayo de 2019
You should not ignore this error (bug?). In my experience, if your block is Red, then you can have problems if you interact with your block programmatically, e.g., you are not able anymore to set the "logs" of your signals 'on' or 'off' programmatically. A quick workaround for this problem is the following: 1) ensure that all your I/O datatypes are correctly set (into Model Data Editor) 2), select everything from your block and COPY. Now go outside your block (i.e., one level up), and PASTE everything. Now regroup into a new block using the just pasted (yet selected) elements (under windows, CTRL+G). This will re-create a new block, hopefully black instead of red. You can now delete your old red block. I have solved my problems with this workaround.

Patrik el 20 de Feb. de 2014
Thanks for your hint. I did not me with this setting, so at least I assume this is not the cause. It seems to want to warn me about an error, unfortunately I were not able to hunt it down to its cause. Mysterious...

Patrik el 10 de Mzo. de 2014
Finally, I did not fix this problem, but started anew and thus, a solution is no more required.


Más información sobre Programmatic Model Editing en Help Center y File Exchange.



Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by