MATLAB Answers

Gechas
0

Suddenly neural network toolbox doesn't work anymore

Asked by Gechas
on 17 Jun 2014
Latest activity Answered by software on 8 Jul 2019
Hello!
I worked with the neural network toolbox until yesterday when suddenly I got a error message:
At first I thougt that somehow the data I feed into the neural network got corrupted. But after checking this I could rule it out as I cause. To make sure it is not the data I tried the sample data that comes with MATLAB and I get the same error message with the sample data.
If I try to call patternnet(10) in the command window I get the following error message:
>> net=patternnet(10)
Default value is not a member of type "nntype.performance_fcn".
Error using nnetParamInfo (line 28)
Reference to non-existent field 'net_read_only'.
Error in patternnet>get_info (line 85)
info = nnfcnNetwork(mfilename,'Pattern Recognition Neural Network',fcnversion, ...
Error in patternnet (line 41)
if isempty(INFO), INFO = get_info; end
I have R2013b 64-bit. Does anybody have an idea what could be the reason that suddenly the neural network toolbox doesn't work anymore? I would very much appreciate your help.

  0 Comments

Sign in to comment.

2 Answers

Answer by Tunan
on 4 Jul 2014

I have the same problem. All of a sudden, Matlab NN toolbox doesn't work any more. It was fine in May.
When I was trying the nprtool and using the sample data, it doesn't work.
Anybody know what's happening? There is no source code since we are using the GUI.

  6 Comments

This worked for me. I had another MATLAB file called mse.m in my path that was distracting the Toolbox, so I removed it.
Thanks, mse.m was troubling me too. A utility folder for another project was overshadowing MATLAB's libraries.
Thanks a lot John Malik, the problem is resolved!

Sign in to comment.


Answer by software on 8 Jul 2019

Thanks John Malik,

  0 Comments

Sign in to comment.