Error with the PV array simulation

9 views (last 30 days)
Jung Sunghun
Jung Sunghun on 16 Nov 2021
Commented: Jung Sunghun on 3 Dec 2021
Hello,
I am currently trying to simulate a single PV cell which I bought from the following link (https://bit.ly/3CmLLeR).
With the PV cell information given in the above link, I built the attached Simulink model to simulate a PV cell's behavior.
However, outputs of current and voltage sensor are a bit strange. I am expecting the voltage range around 0.682 V and current range around 6.24 A, but the sensor ouputs are too huge as shown in the attached pics.
Is there anyone who can help to solve this problem or give me any related information which I can refer?
Thank you very much.

Answers (1)

Joel Van Sickel
Joel Van Sickel on 29 Nov 2021
Hello Jung,
you are applying a constantly increasing voltage to the output of the solar cell, so you couldn't get a fixed voltage. You can replace the controlled voltage source with the appropriately sized resistor to see if you get the expected voltage and current. For your numbers I'd guess a resistance of 0.1 would be close to what you are looking for. I would also use scopes instead of displays so you can see the time varying behavior of the model.
Regards,
Joel
  1 Comment
Jung Sunghun
Jung Sunghun on 3 Dec 2021
Thank you very much for your suggestion. I will try the above method.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by