ROS Toolbox compatibility with Gazebo

4 views (last 30 days)
With R2021b, the packaged Ubuntu 18.04 VM from MathWorks provides a ROS2 Dashing / Gazebo 9, but what we have installed is Ubuntu 20.04, ROS2 Foxy / Gazebo 11. Is the R2021b ROS Toolbox compatible with this newer combination or will we run into issues ? Thank You

Accepted Answer

Cam Salzberger
Cam Salzberger on 15 Feb 2022
Hello Alexander,
There have been issues communicating between ROS 2 Dashing and Foxy for some users. Here is a page addressing that, and another with additional workarounds. I'm not personally knowledable about Gazebo 9 to Gazebo 11 compatibility.
However, the pre-release of R2022a is available, if you have a license that supports the use of pre-releases. R2022a ROS Toolbox makes use of ROS 2 Foxy for communication and Robotics System Toolbox's Gazebo Co-Simulation is compatible with Gazebo 11. So that may be an option to explore.
-Cam
  2 Comments
Cam Salzberger
Cam Salzberger on 15 Feb 2022
If you are trying to communicate between MATLAB and an installed Foxy environment, then yes. R2022a ROS Toolbox now ships with Foxy, so it will no longer have any version incompatibility.
If you now have the opposite situation from normal, trying to communicate between MATLAB and an installed Dashing environment, then there may be issues in that direction. Modifying which DDS middleware is used for communication (similar to the workaround used to communicate R2021b <-> Foxy) may help to resolve potential issues that have Fast-DDS (Fast-RTPS) as the cause.
-Cam

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by