Borrar filtros
Borrar filtros

STM32F746G Discovery Board Ethernet comm not Working. No board IP assigned

5 visualizaciones (últimos 30 días)
Hello all,
Tried to run the STM32F746G Discovery sample projects for Ethernet communication via UPD/TCP. Neither one is properly working: the STM board has no IP assigned to it (tried with both DHCS and static IP assignment). No IP is visible into my router listed clients that could be the one of the STM.
To better understand the problem, I tried to ping a statically allocated (from Matlab) IP of STM - it worked (received replies, but still the IP was not visible throughout the router clients). Then, I performed some debugging using a port peeker app (TCP/IP Builder) and successfully received data from the UPD Send block of the STM. However, when trying to send data, nothing is received on the STM's UDP RCV block in Simulink. The same error occurs while running the sample projects for Ethernet communication via UPD of the STM32F746G. The IP is not assigned, and nothing is received through the UDP RCV. Moreover, the TCP model is not working at all as the connection is not possible due to the lack of an assigned IP to the STM (server).
What am I missing? Thought also of making a setup in STM32CubeMX to enable the ETH communication and have the ETH drivers brought into the project, but the CubeMX configuration file option is completely unavailable to this discovery board (I do not see why, last time I worked with the STM32F401 Nucleo board I had no issue configuring and assigning such a file to my project). Basically, I ran out of options, and I am looking for some kind help from the community.
Thanks in advance!

Respuestas (1)

Suman Sahu
Suman Sahu el 7 de Abr. de 2023
Hi Tudor,
Here are a few troubleshooting suggestions that you may find helpful:
  1. Check the firmware code: Make sure that the firmware code is properly written and configured to support Ethernet communication. Check that you have enabled the correct drivers in the firmware and that the code is not blocking the IP address assignment process.
  2. Use a network analyser: Use a network analyser tool to monitor the traffic between the Discovery board and the router. This will help you identify any issues with the network configuration or the firmware code. Wireshark is an excellent tool for this purpose.
  3. Update firmware and drivers: Check for any firmware or driver updates for the STM32F746G Discovery board, and update them if necessary. Also, ensure that you are using the latest version of STM32CubeMX.
  4. Try a different router: If you have access to another router, try connecting the STM32F746G Discovery board to it to see if the issue persists. It's possible that there may be a compatibility issue between the board and your current router.
Hope it is helpful.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by