Why do i get error "Attempt to execute SCRIPT varargin as a function:" ?

11 views (last 30 days)
I just tried to use evalin and this error occured, now i have removed evalin and restarted the computer and the error still occurs. Also the run button looks different, now there is a blue bubble with tre dots within. What might be the problem here?
It's a script for a Gui which worked fine until now. I only have one script and i am not calling another script from it or something like that.
I have another gui script which is similar which doesn't give an error. The run button looks different for this script, it looks "normal".
My script is named TestGUI.m. If type the following in the commandwindow the script works:
>> TestGUI
But i still want to be able to run it as usual by pressing the run button.

Accepted Answer

Joakim Magnusson
Joakim Magnusson on 24 Jun 2015
In the drop down menu for the run button, it's possible to edit what's suppose to happen run is pressed. it said:
run: TestGUI(varargin)
so I just changed it to:
run: TestGUI

More Answers (0)


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by