Error occurred while executing External Mode MEX-file 'ext_comm': ExtTargetPktPending() call failed while checking for target pkt

189 views (last 30 days)
For a hardware in the loop test I have my simulation running in external mode on a raspberry pi. The raspberry gets information via the udp receive block from a WAGO PLC unit. I've tested the udp signals in a seperate simulink file and it worked properly. Same thing for the simulation: There is no problem in external mode when I simulate the udp signals with a constant value and a slider gain block. When I combine both files and want to give the udp receive values to the simulation my simulink is not starting and i get the error message above.
I have two udp receive blocks, one is receiving a uint16 and the other one a bool value. When i insert only the uint16 value the simulation is running very slow so i think it is a problem to use the sampled bool value. Could it be a problem that the performance of the raspberry pi is to low or that there is not enough RAM? I wanted to try it with a sample and hold block to generate a signal which is more continuous but i couldn't get the block run fine. Would that be a solution?
I use the ode1 due to the fact that this is the only solver which runs with a good performance with my udp receive uint16 value. Would it be better to use the discrete solver for that type of application? I haven't tried that so far because I have a lot of continuous functions in my simulation which i would have to transfer to discrete ones.
  5 Comments
Rashmika Vindana
Rashmika Vindana on 8 Feb 2021
If anyone can slove this problem,please let me know.It is help me for my undergraduate project.
rashmikakv@gmail.com

Sign in to comment.

Answers (3)

serhat çetin
serhat çetin on 20 Apr 2019
Edited: serhat çetin on 22 Apr 2019
1- Check the baundrate(from device manager)
on the command window;
2-
>>codertarget.arduinobase.registry.setBaudRate('untitled',9600)
untitled is sample simulink folder name, write the what your folder name.
9600 is the sample baundrate, write your baundrate.
check the baundrate:
>>codertarget.arduinobase.registry.setBaudRate('untitled')
then connect external mode...
Best regards
  1 Comment
Riccardo
Riccardo on 28 Oct 2022
well, if I write codertarget on matlab, it tellsme unrecognized function and so on.... it doesn't work for me

Sign in to comment.


Pavel Roslovets
Pavel Roslovets on 13 Jan 2016

Noor Zeid
Noor Zeid on 5 Mar 2017
Hi I have the same problem, if you found a solution please email me nozeid@gmail.com thanks

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by