My EDITOR tab is disabled.

35 visualizaciones (últimos 30 días)
Teeratorn Kadeethum
Teeratorn Kadeethum el 2 de Mzo. de 2016
Respondida: amit sason el 7 de Mayo de 2023
When I running my m file, and I break it to run line by line. I don't why my Step button (F10), step in, step out, and also Quit debugging are disabled. How can I turn it on?

Respuesta aceptada

Sean de Wolski
Sean de Wolski el 2 de Mzo. de 2016
You need to be in debug mode. Put a break point on the line and then run the file. NOTE You can not debug sections so you will need to run the file with Run button or by calling the filename.

Más respuestas (10)

Teeratorn Kadeethum
Teeratorn Kadeethum el 2 de Mzo. de 2016
Hi,
Thank you very much for your help. As you can see in my picture, most of the buttons are disabled, even though I'm in a debug mode.
Meen

Andreas Georgiou
Andreas Georgiou el 25 de Oct. de 2016
Hello Teeratorn Kadeethum
I have a similar problem. When I terminate a script with CTRL+C all Matlab Run commands are grayed out. This can be sorted out if you close your script and reopen it. It seems to be a Matlab bug to me... Tried F5, return, dbcont or dbquit but nothing seems to work. The fact that you have to close the script and reopen it makes me think that is something to do with Matlab not realising that the script has ended.

Efstratios Batzelis
Efstratios Batzelis el 20 de Feb. de 2017
I have exactly the same problem. Any news?

Cynthia Waltho
Cynthia Waltho el 9 de Mzo. de 2017
I am having the same issue. On my lab computer (at school), when I try to debug a function (run and stop at a breakpoint) all progression buttons are grayed, meaning I cannot step through or stop the debugging. All I can do is "Run to Cursor" which is very frustrating. This computer has MatlabR2015b and MatlabR2015a installed on it, and this issue exists in both.
On my personal computer Matlab runs perfectly. So whats going on? Are there permission issues? Please help!

Zhang Hu
Zhang Hu el 14 de Ag. de 2017
i have the same question too.

Mojtaba Moravej
Mojtaba Moravej el 4 de Abr. de 2019
I had the same issue. my script calls and runs some functions which I wrote in different matlab files. I just ran another script which was for the test and the problem solved. also, reopening it works.

Wim Mulder
Wim Mulder el 13 de Ag. de 2019
If the breakpoints are gray, you have to first save the file.

Ahmed
Ahmed el 23 de Jul. de 2020
Editada: Ahmed el 23 de Jul. de 2020
If it does not give the option of step in the editor box and the script refers to the simulink model, set a break point and run the simulink model. This will enable the step option.

Joost R
Joost R el 1 de Jun. de 2021
I had the same issue. I think I solved it by repairing my pathdef, which was corrupted (there was a rogue newline in the p-array).

amit sason
amit sason el 7 de Mayo de 2023
it happened to me too, it turns out that the keyboard function lock was turned on.
To disable it try pressing Fn+Esc and then try using the F buttons.
It solved the problem for me!

Categorías

Más información sobre Interactive Model Editing en Help Center y File Exchange.

Etiquetas

Productos

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by