I am having problem in external connection​('ext_seri​al_win32_c​omm') error. How can I fix it?

5 views (last 30 days)
I am using TI c2000 microcontroller. I would like to read the encoder value from the motor. However, even thoguh its pyhsical connections are correct it gives the following error during run process in Simulink:
Error occurred while executing External Mode MEX-file 'ext_serial_win32_comm': Failed to connect to the target. A time-out occurred while waiting for the connection response from the target. Possible reasons for the time-out: a) The target is not switched on. b) The target is not connected to your host machine. c) The application for the model is not running on the target. You might have clicked the Stop button. If the Run button is not dimmed, click it. Otherwise, click the Build button, which downloads and runs your application on the target.
  2 Comments
ummul ghafir
ummul ghafir on 14 May 2017
I am also having problem in external connection('ext_serial_win32_comm') error. i am using arduino mega ADK. i checked the port number as in matlab. and i set it same as the port number of arduino mega adk in device manager.but still matlab cannot detect the target hardware. btw, im using R2015b. How can I fix it?

Sign in to comment.

Answers (2)

Venkatachala Sarma
Venkatachala Sarma on 6 May 2016
Edited: Venkatachala Sarma on 6 May 2016
Hi Mahmut,
Two things to make sure.
1. Com Port in the External Mode tab in the Hardware Implementation pane of Configuration Parameters. This should match with the device Com port shown by the Device Manager.
2. SCI_A is usually the serial port of the target which transfers data during External mode. So the Port Settings shown by Device Manager should be the same as the ones available in the SCI_A tab of Hardware Implementation pane in Configuration Parameters.
Hope this helps

ummul ghafir
ummul ghafir on 14 May 2017
I am also having problem in external connection('ext_serial_win32_comm') error. i am using arduino mega ADK. i checked the port number as in matlab. and i set it same as the port number of arduino mega adk in device manager.but still matlab cannot detect the target hardware. btw, im using R2015b. How can I fix it?

Categories

Find more on Simulink Support Package for Arduino Hardware in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by