MATLAB Answers

J S
4

How do I display more than 16 columns of a cell array?

Asked by J S
on 7 Jun 2016
Latest activity Commented on by Pankaj Chauhan on 22 Jan 2018
I have an 11x65 cell array. If I open it in variable window, only 16 of the 65 columns are displayed. I found no option to change max number of cols. I found the problem in 2015a and 2016a. In 2012b, however, all 65 columns are shown. The problem does not occur with structs.
EDIT: Things are starting to get creepy: Today a big array (40000x65) first showed 24 columns, and then all the other columns as well. I don't know how to reproduce when it works and when it does not. Today, 2 large tables were also open in the variable window. Perhaps that's the motivation for MATLAB to also show the ramaining cell columns. Or maybe there is a connection to free RAM?

  4 Comments

Show 1 older comment
Did you try celldisp()?
"number of columns fitting into the window" would depend upon the Workspace variables formatting preference or the formatting setting chosen for the variable in View -- but it doesn't.
I do agree, though, that it has something to do with the window width at the time you ask to view the variable, such as with openvar(). Windows below a certain width result in 16 columns being displayed; above the minimum width and up to some other width it is 24 columns; at some relatively wide point it gets to 32 columns. Possibly if someone were using a monitor wider than mine more columns could be reached.
@Image Analyst: celldisp() only prints the content in the command window, not variable window. @Walter Robertson: I extended Matlab over my 2 screens as far as I could (there is a limit). Same result.

Sign in to comment.

Products

2 Answers

Answer by James Cheong on 20 Jul 2016
Edited by Walter Roberson
on 7 Sep 2016
 Accepted Answer

Hi there
I had the same problem as well after upgrading to R2016a but there's a MATLAB bug fix.
Hope that helps.
:)

  2 Comments

Thanks, that did the trick! URL didn't work for me, though (with au.) http://www.mathworks.com/support/bugreports/1350885
Thank you, that trick worked for me...

Sign in to comment.


Answer by TREDWISE
on 14 Jul 2016
Edited by TREDWISE
on 14 Jul 2016

This glitch is affecting me as well for r2016 on Mac OS X

  0 Comments

Sign in to comment.