MATLAB Answers

Application Compiler crashes when selecting main file on Windows 10 R2017a

10 views (last 30 days)
Michael L
Michael L on 19 Jul 2017
Commented: rob on 18 Feb 2018
Hi,
I'm trying to compile my AppDesigner (.mlapp) into a stand alone program using applicationCompiler.
When opening applicationControler, everything looks fine. Then I go to "Add main file" and press the + button. I select my .mlapp file (I can also select any m file with the same result). MATLAB Compiler window (and main MATLAB) will hang, and be unresponsive to all inputs/commands. The only way is to force quit (Through Task Manager - End Task) and restart MATLAB. I'm not getting any error messages or other signs, so I have no idea what is wrong.
Some more information: I've successfully been able to compile and distribute the app on Mac. Now, I am attempting to do it in Windows. I have R2017a installed on Windows 10. I have Microsoft Windows SDK for Windows 7 (7.1) installed after following some of the other StackOverflow and MATLAB forums.

  1 Comment

rob
rob on 18 Feb 2018
I'm having the exact same issue. The command line approach works fairly ok but I was wondering if someone solved the issue of the deploytool.
Thank you in advance, Rob

Sign in to comment.

Accepted Answer

Harsh
Harsh on 21 Jul 2017
One of the things you can try is to compile the application directly from the MATLAB command window rather than using the deploytool. The command would look similar to the following:
mcc -o app1 -W WinMain:app1 -T link:exe -d C:\Users\userName\Downloads\mlapp\for_testing -v C:\Users\UserName\Downloads\app1.mlapp -r 'C:\Program Files\MATLAB\R2017a\toolbox\compiler\Resources\default_icon.ico'
As a reference for the exact command, you can also take a look at the packaging log that was generated for the Mac App.
More details on the mcc options can be found here .
However, if the issue persists, please contact MathWorks Technical Support here: https://www.mathworks.com/support/contact_us/
Please be sure to provide a detailed description of the issue and attach any relevant files / code / examples required to investigate the issue.

  1 Comment

Michael L
Michael L on 3 Aug 2017
Thanks! Command line worked. Not sure why the interface isn't working. This one did the trick for me!
mcc -o CompiledName -m -v AppName.mlapp

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by