MATLAB Answers

Rolf
0

Installed OS Generic Video but no linuxvideo adaptor found (R2016a - Ubuntu)

Asked by Rolf
on 4 Sep 2017
Latest activity Commented on by Rolf
on 13 Mar 2018
I used >>supportPackageInstaller to install "OS Generic Video", but for some reason 'linuxvideo' is still not to be found. More details in the image.

  0 Comments

Sign in to comment.

1 Answer

Answer by Shashank on 7 Sep 2017

  3 Comments

Thanks for your reply. Unfortunately, it did not help. Based on your suggestions I tried the following:
Install V4L2:
sudo add-apt-repository "deb http://ubuntu.mirror.cambrium.nl/ubuntu/ `lsb_release -cs` main universe"
sudo apt-get update
sudo apt-get install gem-plugin-v4l2
Than, I copied mwlinuxvideoimaq.so from the toolbox folder:
/root/Documents/MATLAB/SupportPackages/R2016a/toolbox/imaq/supportpackages/genericvideo/adaptor/glnxa64
After, I removed all files in that folder and placed back mwlinuxvideoimaq.so, I rebooted Matlab.
>> checked if it worked (still didn't).
Last, I reinstalled OS Generic Video using supportPackageInstaller and rebooted the computer.
>> checked if it worked (still didn't).
Forgot to mention last time, but all other programs that use a webcam work as expected on the computer (e.g., cheese, etc.).
Hi,
I have the exact same issue, did you find a solution?
Unfortunately, it seems to be a problem that remains unsolved by the community. I 'solved' it by switching to Windows OS.

Sign in to comment.