MATLAB Answers

1

OSError: MATLAB Engine for Python supports Python version 2.7, 3.4 and 3.5, but your version of Python is 3.6

Asked by Debanjan Chakrabarti on 14 Sep 2017
Latest activity Commented on by Seth Koehler on 29 Sep 2017
I am trying to install the Matlab engine module for python, but I am encountering the following error: "OSError: MATLAB Engine for Python supports Python version 2.7, 3.4 and 3.5, but your version of Python is 3.6". Is there an updated setup file for the module?

  0 Comments

Sign in to comment.

1 Answer

Answer by Shashank on 18 Sep 2017
Edited by Shashank on 18 Sep 2017

Hi Debanjan,
Currently, we do not support Python 3.6 as mentioned here :
An updated module with support for Python 3.6 will be available in one our future releases.
- Shashank

  1 Comment

I am having the same issue, however we have activated a python 3.4 environment and the setup file throws the same error. I've attached a screenshot of the command window.

Sign in to comment.