HC-SR04 library listArduinoLibraries is not showing it.

3 views (last 30 days)
HI i have copied HC-SR04 library to default folder i.e arduino\libraries\ yet listArduinoLibraries is not showing it. please advise actions

Answers (3)

Madhu Govindarajan
Madhu Govindarajan on 26 Oct 2017
Edited: Walter Roberson on 9 Feb 2019
Please follow all the instructions provided in that order -
Important: Before using this add-on library in MATLAB, you need to install the Ultrasonic Arduino library. Here are the instructions: 1. Download the zip file from https://github.com/JRodrigoTech/Ultrasonic-HC-SR04/archive/master.zip 2. Unpackage the zip into local directory and rename the folder to ‘Ultrasonic’. 3. Move the ‘Ultrasonic’ folder into the "libraries" folder inside your Arduino sketchbook folder: On Windows, the default path is "Documents\Arduino\libraries\" On Mac, the default path is "~/Documents/Arduino/libraries/" On Linux, the default path is "/home/<username>/Arduino/libraries"

Sign in to comment.

vladimir so
vladimir so on 24 Feb 2018
They could explain where exactly this file should be copied.
I have copied everywhere but when writing: listArduinoLibraries in matlab I only get it: 'Adafruit / MotorShieldV2'      'I2C'      'SPI'      'Servo'
  1 Comment
Madhu Govindarajan
Madhu Govindarajan on 26 Feb 2018
Have you tried the commands provided in this answer ? If not, please try it with your library name - I would guess some version that involves 'JRodrigoTech/HCSR04' should fix the issue.

Sign in to comment.

Thulasiram Reddy
Thulasiram Reddy on 9 Feb 2019
iam using matlab 2016a version and i installed arduino matlab support packages
i want to interface ultrasonicsensor with matlab but the addon is not showing in matlab after that i seted path i given command "listArduinoLibraries" it showing
afer that i again given command a = arduino('COM6', 'Uno', 'Libraries', 'JRodrigoTech/HCSR04')
Updating server code on board Uno (COM6). Please wait.
Cannot program board Uno (COM6). Please make sure the board is supported and the port and board type are correct.
?????????????whycoming like this...
  1 Comment
Madhu Govindarajan
Madhu Govindarajan on 11 Feb 2019
Have you tried putting the board into bootloader mode by double pressing the Reset button?

Sign in to comment.


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by