Parrot minidrone not taking the software update.

6 views (last 30 days)
John Judge
John Judge on 21 Jan 2018
Commented: John Judge on 14 Feb 2018
I have a new Rolling Spider mini-drone, and it will not update with the Matlab firmware. I have tried many times and with both Matlab2017A and Matlab2017B. Has anyone else had this issue? what did you do to get it to update>
  3 Comments

Sign in to comment.

Answers (3)

Ankur Bose
Ankur Bose on 29 Jan 2018
Hi All,
We have contacted Parrot regarding this issue and they have provided us a workaround to resolve this issue. The fix has already been published in R2017b in the support package version 17.2.3. Please upgrade your support package version to 17.2.3 in R2017b and perform the hardware setup for Parrot Rolling Spider once more.
If you do not wish to upgrade your support package, you can follow the below steps to resolve this issue.
  1. Connect the Parrot Rolling Spider drone to PC. Wait for the LEDs to stabilize to RED and GREEN.
  2. If you are working in Windows PC, install RNDIS as mentioned in this link. Please note that drone has a timeout period of approx 60 seconds after which it automatically disconnects from PC. Hence please complete the RNDIS installation as fast as possible.
  3. Open Windows command prompt. Execute the below command in the command prompt as shown in the snapshot.
telnet 192.168.2.1
If you get an error 'telnet' is not recognized as an internal or external command, operable program or batch file, you need to enable telnet in your Windows PC. Follow the instructions in this MATLAB answer to enable telnet in your PC.
If the command prompt displays the message Connecting to 192.168.2.1...... for a long time and then it fails, it might be that the drone has timed out or the RNDIS installation has not gone through.
Reconnect the drone and repeat Step 3. If you still get same error, you need to install RNDIS on the host computer again as mentioned in Step 2. Complete the RNDIS installation as fast as possible.
On successful execution of the command you should see a command prompt window as shown in the snapshot.
  1. On the Delos prompt in the command window, execute the below command
echo "1.99.2" > /version.txt
This would create the missing version.txt in the root folder of the drone, that is required for the firmware update to be successful.
If you get any write permission error while executing this command, try rebooting the drone and repeat the above steps.
After successful execution of the above command, complete the hardware setup screens in MATLAB. They should go through without any issue.
  1 Comment
John Judge
John Judge on 29 Jan 2018
I upgraded to 17.2.3 and tied the updated process again. This is the error I got.

Sign in to comment.


John Judge
John Judge on 30 Jan 2018
I have tried again after a computer restart. I get the same error that things have timed out, but the drone does look to have turned off. Still, one red led and one green led. There is now a test file on the drone which wasn't there before, as well as a Debug folder.
  6 Comments
John Judge
John Judge on 5 Feb 2018
I have purchased another Rolling Spider, fearing there was something wrong with the first one. I just tried to update the second drone and it seems to have the outcome. the drone gets updated to the newer software, but errors out before finishing the update.
Why wound the setup need to update software if the software is already up to date? why doesn't it go on and finish the steps?

Sign in to comment.


John Judge
John Judge on 5 Feb 2018
Edited: John Judge on 5 Feb 2018
So I just updated my Mambo drone. I was able to finish the whole update procedure and successfully test the connection. I then tried to run the Parrot Getting Started simulation and I get a different error but it looks like some of the same errors with the spider drone.
  3 Comments
John Judge
John Judge on 14 Feb 2018
This worked on the spider as well, both drones are no paired.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by