Borrar filtros
Borrar filtros

Compiler problems with Model Referencing

8 visualizaciones (últimos 30 días)
Hernández García Ángel
Hernández García Ángel el 3 de Abr. de 2018
Respondida: Keith Rogers el 2 de Mzo. de 2020
Hi all,
When I tried to run my Simulink model in Accelerator mode, it gives me the following error message:
"The model 'Cheste_Microgrid_RMS_v8' is configured to use the compiler 'MinGW64 Compiler (C): Toochain', however the referenced model 'Cell_Temperature' was built with 'LCC64:TMF' which is not compatible for a model reference hierarchy build. Consider configuring all modules to use the same compiler. The Build Process will terminate".
Then, If I run the Simulink Model in Normal mode, it didn't give me these errors and the simulation is completed successfully. I have tried to check "mex -setup" and the compiler working 'MinGW64 Compiler (C)' and I don't understand why Simulink when it's loading the model it doesn't compile the Model Reference 'Cell_Temperature' as the main model 'Cheste_Microgrid_RMS_v8'. I also have tried to run Performance Advisor and it is not able to fix the problem.
King Regards,
  2 comentarios
Syed Hussain
Syed Hussain el 18 de Feb. de 2019
Where you able to solve this issue.? I am also facing this issue with model referencing.
Pablo Nanez
Pablo Nanez el 6 de Mzo. de 2019
Same here, my simulation was running ok, and I start getting this error after I installed MinGW-w64 Compiler from

Iniciar sesión para comentar.

Respuestas (1)

Keith Rogers
Keith Rogers el 2 de Mzo. de 2020
I tried doing what it suggested and copied the contents into new files. That resolved the problem for me.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by