MATLAB Answers

Strange gpu arrayfun behavior

2 views (last 30 days)
nealm on 20 Jul 2018
Commented: Joss Knight on 26 Jul 2018
I have existing code that works but I'd like to accelerate using the GPU version of arrayfun. However the behavior of GPU arrayfun is difficult to understand. According to the documentation the code within the helper function performs scalar operations on the input gpuArray values. However if I try to write my own scalar values the result is unpredictable. To demonstrate, if I have a helper function that look like:
function outArray = simpleTest(inArray)
outArray = inArray * 3.14159;
x = gpuArray(1:4);
y = arrayfun(@simpleTest, x);
y = gather(y)
y =
Columns 1 through 2
0.0000 + 0.0000i 0.0000 + 0.0000i
Columns 3 through 4
0.0000 + 0.0000i 0.0000 + 0.0000i
If I pass the scalar value to the helper function, as shown in the second helper function, it does seem to work:
function outArray = simpleTest2(inArray, scalarValue)
outArray = inArray * scalarValue;
y = arrayfun(@simpleTest2, x, 3.14159);
y = gather(y)
y =
3.1416 6.2832 9.4248 12.5664
Reading the documentation, I know that the scalar values in the calling function are expanded (similar to bsxfun) however I have been unable to get that function, or any other function, to work within the helper function. I know I'm missing something here, I would appreciate the help.
I have Matlab R2018a with Parallel Computing Toolbox and Cuda version 9.0 installed.


Show 2 older comments
OCDER on 24 Jul 2018
Just curious, what does the following return?
which simpleTest
which simpleTest2
nealm on 24 Jul 2018
>> which simpleTest
'simpleTest' not found.
>> which simpleTest2
'simpleTest2' not found.
I placed the simpleTest functions in a script. I also tried calling them from their own files, no difference.
Joss Knight
Joss Knight on 24 Jul 2018
Okay, so the next thing to do is to check and upgrade your driver. What is your device? What is your driver version?

Sign in to comment.

Accepted Answer

nealm on 25 Jul 2018
I found the source of the problem. I use my own "startup.m" file (which only has "addpath" commands) that is executed at the beginning of a Matlab start. The directories that have been added during the startup process appear to interfere with the way gpu arrayfun executes.
If I don't use the startup.m file gpu arrayfun works fine. Curiously, if I manually run the contents of startup.m AFTER starting Matlab - gpu arrayfun also works fine.


Show 3 older comments
nealm on 26 Jul 2018
Next if I put a breakpoint at the first GPU arrayfun and step into it with F11
yTest1 = arrayfun(@axax123, x);
The editor takes me to a matlab classdef called "mtree". Below is a copy and paste of the first 32 lines of mtree
classdef mtree
%MTREE Create and manipulate M parse trees
% This is an experimental program whose behavior and interface is likely
% to change in the future.
properties (SetAccess='protected', GetAccess='protected', Hidden)
T % parse tree array
% column 1: kind of node
% column 2: index of left child
% column 3: index of right child
% column 4: index of next node
% column 5: position of node
% column 6: size of node
% column 7: symbol table index (V)R/
% column 8: string table index
% column 9: index of parent node
% column 10: setting node
% column 11: lefttreepos
% column 12: righttreepos
% column 13: true parent
% column 14: righttreeindex
% column 15: rightfullindex
S % symbol table
C % character strings
IX % index set (default is true for everything)
n % number of nodes
m % sum(IX)
lnos % line number translation
str % input string that created the tree
If I don't use startup.m this doesn't happen and GPU arrayfun functions normally. Also if I run my addpath function by itself AFTER starting Matlab this doesn't happen and GPU arrayfun functions normally.
Copyright 2006-2016 The MathWorks, Inc.
nealm on 26 Jul 2018
Assuming the call to mtree wasn't normal, I checked the files in my path and didn't find any file that uses classdef mtree directly. Then after some work I think I found the culprit; In my path I have a class folder "@char" where I've redefined the method str2double to that from a mex file from the file exchange:
I had relabeled the function from str2doubleq to str2double for convenience and have used it for several years without issue. After removing this user version of "str2double" from the @char folder, GPU arrayfun behaves normally in all test cases.
Not sure if this is a bug in Matlab or just poor coding form by me, but I'll stop relabeling matlab functions to my own user functions.
Joss Knight
Joss Knight on 26 Jul 2018
Thanks for the investigation! I'll have a look at why str2double is involved and whether I can reproduce your issue. MTree is used to do static analysis of your arrayfun function for the GPU, and presumably str2double is being used to convert the text of your literal value. It may well be a bug that it's possible to break arrayfun by shadowing this function.

Sign in to comment.

More Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by