MATLAB Answers

Why do I get the error "LSOpenURLsWithRole() failed with error -10810" when trying to install MATLAB on a Mac?

492 views (last 30 days)
I try to install MATLAB on my Mac. Launching InstallForMacOSX.app doesn't do anything. Launching it in Terminal returns the following error:
LSOpenURLsWithRole() failed with error -10810 for the file /Users/Bob/Downloads/InstallForMacOSX.app.

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 13 Jul 2020
This issue is being currently investigated by MathWorks. As a possible workaround, run the following command in Terminal.
$ sudo open InstallForMacOSX.app/Contents/MacOS/InstallForMacOSX

  5 Comments

Show 2 older comments
Juan Torres-Reveron
Juan Torres-Reveron on 7 Jun 2020
Same problem here. Two separate machines tried with the same issue. Java problem? I had to resort to an older Mac just to get the offline files. The only difference isthe Java version.
Andrea
Andrea on 27 Jun 2020
Same issue here as well, when trying to install Matlab 2020a. I have tried as super user (sudo etc...) but the same error -10810 is generated. I am running MacOS 10.15.5.

Sign in to comment.

More Answers (0)

Tags

No tags entered yet.

Products


Release

R2019a

Translated by