Borrar filtros
Borrar filtros

"Error using matlabshar​ed.interna​l.ssh2Clie​nt"

12 visualizaciones (últimos 30 días)
jarul el 1 de Oct. de 2019
Respondida: Sylvain el 23 de Dic. de 2020
With R2019b version installed I can not run AD9361 SDR software.
The transmit and receive functions can not be run.
I get the following error:
"Error using matlabshared.internal.ssh2client"
Can someone in Matlab, help me to solve this problem?
The new library function introduced for SDR, the "transmitRepeat" function
can not be run.
Thanks for your response in anticipation.

Respuestas (3)

Ben Cunningham
Ben Cunningham el 7 de Oct. de 2019
Editada: Ben Cunningham el 7 de Oct. de 2019

Anqi Hu
Anqi Hu el 17 de Jul. de 2020
Hi, I have the same problem, have you found out any solutions?
  5 comentarios
jarul el 23 de Jul. de 2020
Here is the way how I solved this problem!
When we use matlab to create SD card image it is not complete by itself. I was getting that error. "Error using matlabshared.internal.ssh2client". I struggled for six months.
How did I resolve this error is as follows: I had partially created an SD card image using Matlab and then partly the image is copied from the Linux machine.
The matlab version 2019b is not quite complete. I had struggled quite a lot of time. I had to manually add part of the files from Linux.
Kindly let me know what board are you using? I have the SD card image created for ZC706 as well as zedboard. I can provide a copy of those SD card image for you, if you wish. I am running the SDR on both the boards at present. I am trying for a Multi-SDR transmission and receiving. I get the image, but not 100% accurate. I get 99.70% only.
Hope that it help you.
Anqi Hu
Anqi Hu el 24 de Jul. de 2020
Hi Jarul, I really appreciate your helps. Fun fact that I'm exactly using the same hardware and same version of matlab as yours, which are ZC706+FMCOMMS5 with MATLAB 2019b. Again I got the same error as yours:"Error using matlabshared.internal.ssh2client", lucky for me, I only struggled for two weeks and just solved it today. Although we seemed to have the same problem, my solution is quite different. Just for future reference if anybody googled here and needs it.
My scenario is that:
  1. with the sd image downloaded from official website, I can connect to the board through PuTTY, either using usb port or ethernet port. When connecting with the ethernet, I have to login use the default username and password for linux system, which are root@analog.
  2. with the sd image obtained from seting up zynq hardware support package, this image allow me to communicate with the board using communication toolbox, but the linux system and GUI are not available. It works like another zedboard. I tried to connect to ZC706 with PuTTY and found out the username and password has to be root@root.
  3. Then I guess the problem is that in somewhere Matlab is using root@root to build connections while got rejected by the board. So I changed the the password from analog to root in cmd with simple line: 'passwd root'. problem solved.
It sounds interesting that you are using the zc706 and zedboard at the same time, I tried to use two zedboards simultaneously but got stuck with the prolem of multi-chip synchronization, so I just chose to use FMCOMMS5 with already two chips on it. If you could make it work, I'd like to hear from your success, if you are willing to share with me. I'm so happy that I can find someone to consult and communicate with who seemed to work on the same piece of hardware work.

Iniciar sesión para comentar.

Sylvain el 23 de Dic. de 2020
Same error message, my Pi is wiried to the host PC. After a couple of time working with tune & monitor. I just unplugged the ethernet cable, restart the Rpi, and Matlab to fix this connexion issue.


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by