MATLAB Answers

Problem sending data from ThignSpeak to Simulink

1 view (last 30 days)
Hello!
I have a channel in ThingSpeak. Field number 4: Temperature, with some data. But, when I try to read that data in Simulink, I only receive 0... What could be happening?
Simulink model:
Configuration in simulink
ThingSpeak data:
REsponse:
  2 Comments
Vinicio Moya
Vinicio Moya on 7 Jul 2020
Yes! I’m sure... I’m receiving the data... but always is zero...

Sign in to comment.

Accepted Answer

Reeno Joseph
Reeno Joseph on 9 Jul 2020
Hello Vinicio,
I just tried to read from your thingspeak channel and got the data. I ran the model in “Monitor & Tune” mode and could see the data. Please check the attachment.
To confirm the issue at your end please share the output of status port and the ‘Diagnostic viewer’
Thanks,
Reeno Joseph
  1 Comment
Vinicio Moya
Vinicio Moya on 9 Jul 2020
I had to reinstall the Run Hardware Pi package and it works... Thanks!

Sign in to comment.

More Answers (2)

Vinicio Moya
Vinicio Moya on 7 Jul 2020
I´m trying with another blocks, and with this one, it is working. But, I need send this to run over a Raspberry Pi, and I can not use the ThingSpeak Input block. But, here is obviusly that the problem is in the Raspberry Pi ThingSpeakRead block...

Vinicio Moya
Vinicio Moya on 8 Jul 2020
On the other hand, if I use Raspberry Pi ThingSpeak Write block, it is sending all the time a 0. When manually I change that value with a 20, the system write a 20... But, the value of the constant in the left side is just like it doesn´t exists.

Communities

More Answers in the  ThingSpeak Community

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by