Loading a MAT file gives "Cannot read file", yet sucessfuly loads data into memory.

1 view (last 30 days)
David Leather
David Leather on 19 Nov 2020
Answered: Rohit Pappu on 25 Nov 2020
Hi,
I ran an experiment on a cluster, and noticed 1/10,000 MAT files gave a "cannot read file" error when collecting results. I downloaded the MAT file and confirmed the error. I then reran the script that generated the MAT file, and was given the same error on the new MAT file. Once again, I download the MAT file onto my local machine. I noticed despite the error, MATLAB successfully loads variables into the workspace and they seem to be working fine.
I suppose I shouldn't be compaining but I want to know what is going on....
Obtaining the header from the following code outputs
fid = fopen(fn, 'r');
header = fread(fid,120).';
fclose(fid);
char(header)
MATLAB 5.0 MAT-file, Platform: GLNXA64, Created on: Thu Nov 19 04:19:49 2020
Note that I restarted MATLAB and cleared all multiple times, to ensure the variables were not in my workspace beforehand.

Answers (1)

Rohit Pappu
Rohit Pappu on 25 Nov 2020
There could be a possibility of the file being corrupted. For further analysis, you can use the MATCAT tool , which is available on File Exchange

Products


Release

R2020b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by