Borrar filtros
Borrar filtros

Matlab giving me errors mentioning Java and not running scripts

6 visualizaciones (últimos 30 días)
Deepu George Kurian
Deepu George Kurian el 17 de Mzo. de 2021
Respondida: Manas Meena el 23 de Mzo. de 2021
Whenever I open Matlab this error pops up
Exception in thread "ContributedToolsLoader": java.lang.UnsatisfiedLinkError: no nativei18n in java.library.path
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at com.mathworks.fl.i18n.XMLMessageSystem.<clinit>(Unknown Source)
at com.mathworks.toolstrip.factory.XMLUtils.readResourceBundleAttribute(XMLUtils.java:83)
at com.mathworks.toolstrip.factory.TSToolSetContents.<init>(TSToolSetContents.java:1430)
at com.mathworks.toolstrip.factory.TSToolSetContents.<init>(TSToolSetContents.java:1419)
at com.mathworks.toolstrip.factory.TSToolSetContents.<init>(TSToolSetContents.java:1405)
at com.mathworks.mde.desk.ContributedTools.addToolSet(ContributedTools.java:153)
at com.mathworks.mde.desk.ContributedTools.addToolSet(ContributedTools.java:144)
at com.mathworks.mde.desk.ContributedTools.<init>(ContributedTools.java:67)
at com.mathworks.mde.desk.ContributedToolsLoader$3.run(ContributedToolsLoader.java:68)
at java.lang.Thread.run(Unknown Source)
I am using R2018b and recently made an update (R2018b update 8) after which this started happening, I am not able to open or run scripts. Whenever I try, this error pops up. I tried installing the latest Java JDK and adding the same to the PATH variable, but its still the same.

Respuestas (1)

Manas Meena
Manas Meena el 23 de Mzo. de 2021
You can try to troubleshoot this with the following steps:
  1. On your system go to "security and privacy"
  2. under "privacy" select "full disk access"
  3. assign that privilege to MATLAB.

Categorías

Más información sobre Startup and Shutdown en Help Center y File Exchange.

Productos


Versión

R2018b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by