Simulink Network not working same as Matlab Network

3 visualizaciones (últimos 30 días)
Himanshu Dubara
Himanshu Dubara el 17 de Abr. de 2021
Comentada: Himanshu Dubara el 30 de Abr. de 2021
I have trained and tested a fitnet neural network in matlab. later I tried generating its simulink model to deploy it on raspberry pi using:
gensim(net_voltage1,-1)%net_voltage1 is the name of my network
I then copied the network block and put it in my simulink model.However the output received for the test data in simulink is not the same as that of the output received while testing the nework in matlab. How do I rectify this?

Respuesta aceptada

Maadhav Akula
Maadhav Akula el 22 de Abr. de 2021
Hi Himanshu,
Try setting up the initial conditions of the model using setsiminit, please refer this example.
  2 comentarios
Himanshu Dubara
Himanshu Dubara el 29 de Abr. de 2021
Sorry for the late reply, does the input for preparets need to be in timeseries, or will array do?
Himanshu Dubara
Himanshu Dubara el 30 de Abr. de 2021
On viewing the example it says a simple gensim will do for a feed forward network. However I tried the following
[xs,xi,ai,ts] = preparets(net_voltage1,test_volt_in.Data,{},test_volt_out.Data);
On running this it gave me an error
Error using preparets (line 194)
Number of feedback signals not equal to all feedback (0) or open feedback (0) outputs.
what do I do?

Iniciar sesión para comentar.

Más respuestas (0)


Más información sobre Sequence and Numeric Feature Data Workflows en Help Center y File Exchange.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by