MATLAB Answers

How do I resolve a MATLAB installer fail with an error related to a lxe_win64 or .enc file?

4.854 views (last 30 days)
When installing MATLAB on my machine I get an error similar to the following example:
The following error was detected while installing lxe_win64:
Missing Entry: lxe_win64_1368859906.enc
Missing Entry: lxe_common_1384906630.enc
Would you like to retry installing lxe_win64/lxe_common? If you press NO, the installer will exit without completing the installation. More information can be found at C:\Users\<user_name>\AppData\Local\Temp\mathworks_<user_name>.log

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 17 Mar 2021
Edited: MathWorks Support Team on 17 Mar 2021
Try one or more of the following steps to resolve the issue:
  • This error can be caused by an anti-virus or security program interfering with the MATLAB installer. Disable any anti-virus you have running, and then rerun the installer.
  • There may be an issue with the target installation directory. Rerun the installer and specify a new directory that did not previously exist on the system.
Note: Remove the folder in the following path as well: C:\Users\<username>\AppData\Local\MathWorks\MATLAB\R20XXx
  • If you installed a prerelease of MATLAB, remove the existing prerelease installation. Then, rerun the installer.
  • If you are installing R2018a or older, the files that you downloaded may be corrupt or incomplete. Delete the installation files on your system. Then, download your products again and rerun the installer.
Michael Valasek
Michael Valasek on 24 Sep 2021 at 16:37
To switch off anti-virus is a joke?
I cannot install Matlab after 8 hours of work. Horrible design of installation. Whay is it not done in separate parts? Why is it necessary to start from scratch?
Very unsatisfied.

Sign in to comment.

More Answers (36)

dadou nassim
dadou nassim on 17 Apr 2020
Hello, can you help me with this?
Saul Benitez
Saul Benitez on 27 May 2021
This comment was flagged by DEEPIKA MANDALOJU
I had the same problem. In my case, I had older matlab versions in windows 10 OS. To solve that problem I uninstall older matlab versions and erased its corresponding registers in regedit window.

Sign in to comment.

Ambuj Kumar Gautam
Ambuj Kumar Gautam on 22 Apr 2020
I m installing MATLAB2020. and I am getting null kind of error. Attached as picture.
Please help me to resolve this issue.
Thank You

Sign in to comment.

nelson duarte
nelson duarte on 27 Mar 2020
This answer was flagged by 家祥 王
can anyone help me? i have windows pro and mcfee actived. any suggestion

Sign in to comment.

aderajew asayhe
aderajew asayhe on 22 Mar 2020
I don't know why got error message it.
it's said missing file.

Carlos Orduno-Albarran
Carlos Orduno-Albarran on 5 Feb 2020
Edited: Carlos Orduno-Albarran on 6 Feb 2020
I tried all the other options and none of those fixed my issue, and installing it into a new directory fixed the issue. I just added a 2 at the end of the proposed directory.
this is the issue that I had.
another step that I made, but I'm not sure if that helped, I installed just matlab and simulink first, after it was completed and activated, I installed the rest of the packages.
UPDATE: I just had a similar issue while updating Matlab on my Mac.
m3i_core_maci64_1574371482, m3i_core_maci64
this is what I did, I deleted the folder from Applications and installed first Matlab and Simulink, that avoided the extract error.Screen Shot 2020-02-05 at 4.22.00 PM.png
Walter Roberson
Walter Roberson on 1 Apr 2020
It is strange that a Windows system would want to download a Mac-specific file, m3i_core_maci64.*
When I look through the R2019b installation, it appears that you might be able work around that file being missing by not installing the toolboxes that depend upon it. If you do that, you could at least proceed with the installation, and then come back later to try to do the others, perhaps one at a time.
The toolboxes that want m3i_core* appear to be:
  • Antenna Toolbox
  • Bioinformations Toolbox
  • Deep Learning Toolbox
  • Fixed-Point Designer
  • Image Processing Toolbox
  • MATLAB Coder
  • MATLAB Report Generator
  • RF Toolbox
  • Signal Processing TOolbox
  • SimBiology
  • Simulink
  • Stateflow
  • Symbolic Math
  • Wavelet
I would suggest turning off installing those for the moment, getting everything else installed, and then going back to try to install Simulink.

Sign in to comment.

choudong zemtsop ulrich
choudong zemtsop ulrich on 24 Apr 2020
I had a problem when installing matlab. in fact the intallation could no longer continue because they were missing some files that I don't know

lorenzo ricciardi
lorenzo ricciardi on 5 Mar 2020
Hi, when installing MATLAB on my machine I get an error like the following:
" he following error was detected while downloading 3p/eclipsexbaseruntimelibrary_common_1563491806.enc:
Connection reset
Would you like to retry downloading 3p/eclipsexbaseruntimelibrary_common_1563491806.enc? If you press No, the installer will exit without completing the installation.
i'll wait an answer.

stone wu
stone wu on 20 Mar 2020
What means of “Wrong number bytes:Expected 13043816 got 6661064” appeared on my screen during I installing Matalab R2020a. Pleas show me the way to install Matalab R2020a.
  1 Comment
Walter Roberson
Walter Roberson on 20 Mar 2020
Something interfered with downloading one of the files. You will need to try downloading that part again.

Sign in to comment.

Frederic Noudjeu
Frederic Noudjeu on 22 Mar 2020
i use to try it twice, but didn,t get the right answer to complet the installation.
Please help me
  1 Comment
Nourah Almoallem
Nourah Almoallem on 22 Mar 2020
try to install just matlab and simulink first, after it was completed and activated, then try to install the rest of the packages..

Sign in to comment.

wafaa alesse
wafaa alesse on 24 Mar 2020
try to install just matlab and simulink first, after it was completed and activated, then try to install the rest of the packages.

Koffi Clement YAO
Koffi Clement YAO on 1 Apr 2020
Yes continue

Sign in to comment.

Jerly Yorleth Herreño Galván
Hello, can you help me with this?

Sign in to comment.

Richard L
Richard L on 12 May 2020
I have the same problem before, but solved now.
A line like
Caused by: java.lang.Exception: Read timed out
can be found in the log file which can be export in on macOS by
cp $TMPDIR/mathworks_$USER.log ./
. I realized that my Mac had no java installed.
After installing java with brew, the downloading is in progress well by now.

Kim Olszewski
Kim Olszewski on 14 May 2020
Good morning,
After I installed 2020a it worked. I then went to upgrade the software using 2020a Update 2 shown at
I get the attached error. Mathwork’s solution (as I understand) is at
After this error occurs I can no longer run R2020a. Also I tried to reinstall Matlab 2020a but the installer won’t work after the error occurs and gives the same error again.
I tried to uninstall the R2020a software using Windows and Matlab and the same error screen pops up.
Anybody have a solution.

Chieh-Hsuan Hu
Chieh-Hsuan Hu on 14 Jun 2020
C\Program Files\MATLAB\R2020a\bin\win64\d3dcompiler_47.dll
was refused.

lisa Liang
lisa Liang on 15 Jun 2020
i need to reinstall MatLab because the program could not open properly (tho it had been working before). However, it ran into erroe when i ran the install.exe. Does anyone know what how to solve that? I really need MatLab for data analysis. Thank you!

Sign in to comment.

jiquan zhong
jiquan zhong on 7 Dec 2020
I can't uninstall and re-install for this problem: C:\\ProgramFiles\MATLAB\R2020a\help\matlab\helpsearch\segments_y (System cant't find certain files)

君 钟
君 钟 on 23 Dec 2020
Turn off the security guard installed on your computer, when installing the app. Everything will be okay.