USRP X310 setup error

7 visualizaciones (últimos 30 días)
MOHAMMAD NADIM
MOHAMMAD NADIM el 24 de Jul. de 2023
Comentada: Neil MacEwen el 25 de Jul. de 2023
i tried to validate the radio setup of usrp x310. i used Wireless testbench support package for NI USRP Radios. what can be interpreted with this error? in what scenario, it can impact? and is there any way to rectify this.
  1 comentario
Neil MacEwen
Neil MacEwen el 25 de Jul. de 2023
Hi Mohammad,
The test that has failed here is quite simple. It creates a sine wave at 1/8 of the sampling rate using a dsp.SineWave System object , then transmits it and receives it using the basebandTransceiver object. The received data is analysed using a spectrumAnalyzer object to find the tone frequency that has been received.
There are a few things that could cause this issue, mostly down to your local environment or hardware setup. Did you have antennas or a loopback cable attached to the radio? Did you use an attenuator with a loopback cable? If the received power was not sufficient, the transmit tone may have been lost in the noise, or if there was a large interferer it may have been picked up instead.
You do not need to worry too much about this, you can still continue in the setup wizard to create a radio object and use the rest of the product. I have attached a script that will let you run the same test as the setup wizard, which may help you debug.
Kind regards,
Neil

Iniciar sesión para comentar.

Respuestas (0)

Categorías

Más información sobre Communications Toolbox en Help Center y File Exchange.

Productos


Versión

R2023a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by