Borrar filtros
Borrar filtros

Add-ons, Logging in etc Do Not Work - Linux installation

23 visualizaciones (últimos 30 días)
George Barnett
George Barnett el 15 de Feb. de 2018
Respondida: Jay Vaidya el 4 de Sept. de 2020
I have intalled the latest version of matlab onto a Ubuntu machine. I also installed the support package available on the software library. Matlab works perfectly except certain function do not react at all. This includes using any add-on links, the add-on manager, trying to log in, or even use the request support etc buttons. They are clickable, but nothing happens.
Any help woudl be appreciated
  4 comentarios
Simone Perriello
Simone Perriello el 5 de Dic. de 2018
For archlinux, you have to install libsepol and libselinux from AUR.
N/A
N/A el 6 de Jun. de 2019
Editada: N/A el 6 de Jun. de 2019
@Simone Perriello's answer works and you may also need to install libxss from Arch core repositories. This missing dependency was found from Answer by Joakim Lindblad on 27 Feb 2018

Iniciar sesión para comentar.

Respuestas (5)

Joakim Lindblad
Joakim Lindblad el 27 de Feb. de 2018
To get "Manage Add-Ons" to work: Run from matlab prompt:
>> cd(matlabroot)
>> cd bin/glnxa64
>> !./MATLABWindow -url=http://mathworks.com --disable-gpu
If it tells you 'libselinux.so.1' is missing, then try to install it (I don't know where to find it on Ubuntu; on Gentoo I run 'emerge libselinux')
  6 comentarios
Joakim Lindblad
Joakim Lindblad el 30 de Oct. de 2019
Ok, a year and so later, I'm back at the same problem. This time I got as output from:
!./MATLABWindow -url=http://mathworks.com --disable-gpu
./MATLABWindow: symbol lookup error: /usr/lib64/libatk-1.0.so.0: undefined symbol: g_log_structured_standard
This was solved by
Then the Add-ons window worked, however, no typing! Gah!
Copy pasting stuff into the dialog boxes was enough for me...
Some internet sources say it works if you're root, but then my licence manager complained.
Luither Clark
Luither Clark el 24 de Abr. de 2020
Another library that needs to be present is libXss.so.1, which is installed by the libXScrnSaver package on RHEL 8.

Iniciar sesión para comentar.


Rogier Delporte
Rogier Delporte el 13 de Mzo. de 2019
I'm having a similar issue: I can open the addon explorer and the sign in, but whenever I go to click on a textbox, I cannot fill out the field.
I've tried setting aside the libraries mentioned in https://nl.mathworks.com/matlabcentral/answers/364551-why-is-matlab-unable-to-run-the-matlabwindow-application-on-linux, but that did not help at all.
I'm running Ubuntu 18.10, kernel 4.18.0-16-generic, MATLAB version 9.5.0.944444 (R2018b).
  1 comentario
yannick
yannick el 19 de Mzo. de 2019
I had the same issue, no textbox was working. Having started MATLAB with root privilege (sudo matlab) it works fine.
Hope that helps.

Iniciar sesión para comentar.


Kirk Walla
Kirk Walla el 22 de Jul. de 2019
I've encountered the same issue where the install update and sign in buttons were unresponsinve. I am on arch linux and after installing libselinux thinks started to work but now I have the following strange behaviour where whenever I press the button install updates it oscilates between R2018 update 2 and R2018 update 4 and it never goes beyond that in updating for instance to R2019a. I don't know is this the default behaviour or if something is not working completely.
If anyone has any ideas plz let me know. Thanks!

Kirk Walla
Kirk Walla el 22 de Jul. de 2019
I had the same issue on arch linux and after installing libselinux things started to work but now if I press the install update button it oscilates between R2018 update 2 and R2018 update 4 without going beyond that, for instance in updating to R2019a. Is that normal behaviour? Thanks!

Jay Vaidya
Jay Vaidya el 4 de Sept. de 2020
Please try to run the following in the MATLAB Command Window:
>> opengl software
And then try opening the Add on explorer again. It worked for me.
If that works, you can save the preference so that MATLAB always opens with Software OpenGL by running:
>> opengl('save','software')

Categorías

Más información sobre Introduction to Installation and Licensing en Help Center y File Exchange.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by