MATLAB Answers

Do you suffer from keyboard latency in this forum?

10 views (last 30 days)
Jan
Jan on 15 Apr 2011
Commented: Jan on 8 May 2019
Creating answers and questions is very tedious on my computer: Each keystroke takes between 0.8 and 1.5 seconds to appear in the input mask. Even if I use an external editor the workflow is such horribly slow, that I cannot feel it "flowing" at all.
Of course I can type a message blindly, but this increases the number of typos even further. Then editing the message is a challenge: To delete 4 characters and insert 4 new ones, I have to wait 8 seconds plus 2 additional seconds to see, if really every keystroke was processed.
Using the mouse to set the cursor yields to further problems: keyboard events and mouse events are collected in different queues.
[Key1], [move cursor by mouse click], [Key2]
results in:
[Key1], [Key2], [move cursor by mouse click]
Of course using automatic key repetition is absolutely impossible under these circumstances such that I get the ancient type-writer feeling.
I admit that I'm using an older computer for the internet access and have a 36Mbps connection only. But the only limitations I get are:
  • no files access for >500MB
  • no HD-movies
  • no Areo-look (transparent windows)
  • no bearable editing in MATLAB Answers
Am I the only one with such problems?
PS. Creating this message took 32 minutes.

  2 Comments

Jan
Jan on 15 Apr 2011
I tried to edit my question, but stopped after waiting for 2 minutes to insert:
EDITED: I'm accessing the MathWorks server from Germany using Firefox 3.6 with NoScript (disabling this does not help).
Jan
Jan on 18 May 2012
BUMP after Walter's new answer in the wish list.

Sign in to comment.

Accepted Answer

Randy Souza
Randy Souza on 12 May 2011
I'd like to reassure everyone that solving this problem is a priority for us, and we hope to have some improvements in place Real Soon Now™.
Thanks for your detailed feedback and workarounds!
(I'll be sure to update Jan when we think we've improved the situation).

  14 Comments

Image Analyst
Image Analyst on 20 Sep 2013
Yeah, I don't think Walter sleeps. Though he's normally in Canada I've seen time stamps at all hours of the day and night for him.
Jan
Jan on 11 Nov 2017
Please note that I am still waiting for information from MathWorks...
Jan
Jan on 8 May 2019
@Randy: The keyboard latency has grown again in the last days. I'm still waiting for a message, when this problem is fixed. After 8 years I assume the source of the problem is known already.

Sign in to comment.

More Answers (18)

Aurelien Queffurust
Aurelien Queffurust on 15 Apr 2011
I have no issue.
PS. Creating this message took 1 second. :)

  1 Comment

Jan
Jan on 15 Apr 2011
Nice for you, even worse for my emotions.

Sign in to comment.


the cyclist
the cyclist on 15 Apr 2011
I have no noticeable keyboard latency here.

  1 Comment

Jan
Jan on 15 Apr 2011
From which country do you access the MathWorks server?

Sign in to comment.


Clemens
Clemens on 15 Apr 2011
Such a behaviour I experience only when working through remote desktop.
What browser are you using?
On a related matter - I immediately install NoScript and Flashblock in my browser. Using these even my old eee offers nice speed.
But I'll give this site a try on it at weekend.

  1 Comment

Jan
Jan on 15 Apr 2011
I'm using NoScript already to block the forwarding of my IP address to Google-Analytics.
Btw. a German web site owner was accused for using Google-Analytics, because this conflicts with the laws for protection of privacy. I do not like that Google knows which books I'm looking for at Amazon during I'm browsing on the MathWorks pages.
I'll tried it at every time of the day (except between 3:30 to 6:30 UTC) and at every day of the week in the last 2 month. The latency disappears immediately if I disable the preview by hacking the page, or if I paste a very large text block at first, such that the auto-preview is disabled automatically.
I've asked files@mathworks to insert a method do let me disable the auto-preview manually and I'm desperately waiting for this feature. Well. I think this is the problem: I should stop waiting desperately and leave this forum.

Sign in to comment.


Sean de Wolski
Sean de Wolski on 15 Apr 2011
No issues, Jan. Mac OSX running Firefox in USA (though some argue that we're actually part of Canada ;-) ).

  2 Comments

Jan
Jan on 15 Apr 2011
Cruel. And I'm convinced that Walter has no latency also: Otherwise he had to start writing his answers in 2007.
Summary: No problems in Canada, USA, Austria, and no problem of the browser.
Walter Roberson
Walter Roberson on 15 Apr 2011
I do get latency, but not nearly as much as Jan. The latency varies some with time of day, but often seems random.

Sign in to comment.


Matt Fig
Matt Fig on 15 Apr 2011
I do have such issues, but very inconsistently. Over the last few days it has been driving me nuts. For a few weeks before that there was no problem. Yesterday it took 10 minutes to write a single sentence, that is for it to show up. I typed blindly then went and got some coffee and came back to the last word showing up.
Today it is better, no delay at all. I wish I could find the pattern!
I am using the latest Firefox and 1 Mbps connection. 36 Mbps is a way fast connection, Jan - at least in the rural areas of Idaho, USA. In fact, when I was on campus at MSU a few years back they had the fastest internet connection in the state: 20 Mbps. I could watch HD all day long on that connection with no problem....

  2 Comments

Jan
Jan on 15 Apr 2011
Walter, Matt and Jan suffer from latency, others don't. If Paulo and Matt Tearle get latency also, the pattern is clear: The server tries to get rid of the top 5 users. Or if Andrew Newel gets impeded also, the limit is 500 reputation points.
I think going paranoid is better than getting frustrated.
Matt Tearle
Matt Tearle on 15 Apr 2011
Inconclusive answer from me: no lag at work, but lag at home. BUT work = TMW, so you'd kinda hope there was no lag there :). And home usually means I'm on my iPad far from the wireless router. So I wouldn't read much into that.

Sign in to comment.


Andrew Newell
Andrew Newell on 15 Apr 2011
I don't experience any latency. My download speed is 10Mbps and my upload is 500kbps - isn't the latter more relevant for keyboard latency? Like Sean de, I run Firefox on MacOSX in the U.S. (all latest versions).
Jan, if 36Mbps is a slow speed where you are, what is a fast speed?

  6 Comments

Show 3 older comments
Jan
Jan on 15 Apr 2011
@Andrew: I'm using an editor usually. But for the formatting some tiny changes are needed, e.g. for line breaks in the source code - otherwise the preview field would be absolutely useless.
@Walter: I have 22-27ms for small packets and 40ms for 512byte pakets to www.mathworks.com without any drops. I never had such experiences in other forums or telnet sessions.
Thanks to all for your assistence!
Walter Roberson
Walter Roberson on 15 Apr 2011
It appears that I am averaging 27-32 ms from home.
Note that www.mathworks.com is not one single server. It resolves to www.mathworks.com.edgekey.net which resolves to e218.b.akamaiedge.net . From work that resolves to 96.6.160.244 and from home that resolves to 184.29.208.244 . Akamai specializes in distributed web service; it is possible that you are getting forwarded to one with bad performance.
Jan
Jan on 19 Apr 2011
@Walter: Thanks for these details. I get 38-42ms without drops for 512byte pakets to e218.b.akamaiedge.net. This is comparable to the access to other forum servers - but they do not have a live preview but need a manual trigger. I'd prefer this feature here also.

Sign in to comment.


Jennifer
Jennifer on 19 Apr 2011
I too get this issue but only occasionally - no idea why this is sometimes the case and other times it is relatively easy. Could it be just down to the number of users accessing the site?

  1 Comment

Jan
Jan on 19 Apr 2011
Thanks for your support. I've tried it at different times between 3:30 to 6:30 UTC, and I did not get significant differences. The problem appeared on my computer in the first week also, when the traffic was lower here.

Sign in to comment.


Oleg Komarov
Oleg Komarov on 25 Apr 2011
Got latency problems on 26th of April for writing a longer-than-usual post, but really not severe as Jan's.

  1 Comment

Matt Fig
Matt Fig on 26 Apr 2011
I too got latency problems today. It was horrible! It was as slow as it has ever been.

Sign in to comment.


Paulo Silva
Paulo Silva on 26 Apr 2011
I notice no latency besides the one in my brain lol , the time it takes me to remember something is far greater than any possible latency :)

  0 Comments

Sign in to comment.


Jan
Jan on 11 May 2011
- Shameless bump -
MATLAB Answers is on air for 100 days now. Congratulations! I appreciate the layout features and the (too rarely used) possibility to embed pictures. Commenting otherones answers and editing the own posts is a powerful method to improve the quality of the data base.
But the latency drives me crazy. I'm loosing too much time waiting for this GUI to process my keystrokes. The mechanism to disable the auto-preview is implemented already, but it is triggered after a huge number of keystrokes only.
I stop posting until this problem is solved. I'd apprciate it very much, if somebody could send me a message. Thanks!

  2 Comments

Andrew Newell
Andrew Newell on 11 May 2011
That's a big loss to this forum. I hope they solve it soon!
Jan
Jan on 12 May 2011
Thanks, Andrew. I'm sure others will fill this gap. Until today only 1413 questions are waiting for an answer.

Sign in to comment.


Andrew Newell
Andrew Newell on 11 May 2011
Here is an approach that I hope will make life easier for people with keyboard latency that is not too extreme. I used it to write this question.
  1. Write your answer in the MATLAB editor. Comments have '% ' infront of them; code gets the two indent spaces. You can test youranswer as you compose it.
  2. When you are ready to submit your answer,just do a global replace of '% ' by a blank, and you're in business! (Unless, of course, you happened to insert '% ' in the answer itself.)
  3. If you want to include the output to your commands, cut and paste it into the MATLAB editor.
Even without any keyboard latency, I prefer doing it this way for all but the shortest comments.

  4 Comments

Show 1 older comment
Andrew Newell
Andrew Newell on 11 May 2011
I'm not saying it's a good situation, but at least it doesn't interfere with your thought process while composing the message.
Walter Roberson
Walter Roberson on 11 May 2011
When it takes tens of minutes just to wait for the preview to catch up so that you can save the message, then that is a major impediment to participation.
Andrew Newell
Andrew Newell on 11 May 2011
All right, all right! I deleted the first line from my answer. I still hope that my algorithm for composing answers makes someone's life easier.

Sign in to comment.


Jan
Jan on 10 Aug 2011
3 weeks later after my last comment to Randy...
I gave up. Because MATLAB Answers is a valuable platform and my time is too expensive to waste it by waiting for characters to appear, I bought a faster computer. A Core2Duo 2.3GHz, 2GB, Win7-64 is enough to send some keystrokes to the TMW servers and see them appearing fluently in my browser.
Well. Forcing users to apply brute force is not a smart solution.

  0 Comments

Sign in to comment.


cr
cr on 11 Aug 2011
I dont post too often, but I tried this out of curiosity. No issues. On Safari, running OSX.

  0 Comments

Sign in to comment.


Daniel Shub
Daniel Shub on 18 May 2012
At times yes.
64-bit Linux and Firefox 32-bit Windows and Explorer

  0 Comments

Sign in to comment.


Walter Roberson
Walter Roberson on 22 Jun 2012
Recently, for a month or so, it was taking me 24 seconds to fully load an Answers page in a new tab, when accessing via a 3 Gb/s connection. It also was not uncommon for me to get about 5 lines ahead in my typing, waiting for the preview to catch up. This was, it might be imagined, rather frustrating.
The 24 second load time turned out to be a problem in my graphics driver (!!)
The very long latencies for preview to catch up were somehow related to that, but only as a matter of degree: those same days, at home, I was often getting 2 or more lines ahead in plain typing.

  4 Comments

Show 1 older comment
Image Analyst
Image Analyst on 23 Jun 2012
Is it that way for you on all computers you try (presumably with different graphics cards), or just your main one? (Although I know if you tried it on any of mine, there would be no lag).
Walter Roberson
Walter Roberson on 23 Jun 2012
One of the more frustrating parts waiting for typing to catch up is that for whatever reason it is not possible to switch tabs and read or type something else while it is processing. The very long times to load answers, at least I could switch tabs and read something I had started a load of at an earlier point.
Especially at home, it is not uncommon for me (i.e., several times per day) to get inexplicable delays in rendering the Answers pages at all (especially the main page) if the tab name doesn't paint within about 10 seconds then the page might take more than half an hour to load (before I give up and kill the attempt.) It is not consistent: if I middle-click several Questions (Load In New Tab), some of them might load in a small number of seconds and others might go into indefinite time.
I did encounter something identifiable today: Questions mostly painting but the Answer portion of them not, but if left for sufficiently long they would resolve. I realized that the default avatar was failing to load (the gray outline of a head.) I had that happen once before and at the time tracked it down to the fact that browser plug-in update had automatically self-installed but was waiting for a restart to finish installing. So when I noticed the picture problem today I re-started my browser, and that did seem to help (even though no browser update was waiting this time.)
So that's a number of different latency issues, some more tractable than others. But in the meantime if we could just get a method to Turn Off The Preview, that would help a lot!!
IA: the 24 second issue was my (older Dell, NVidia, Unbutu, very high speed internet) desktop at work. The graphics driver mismatch on that one was a mix of my fault and a kernel problem. The lesser problem of 2-lines ahead in typing was at home (older Mac with OS-X, basic cable modem). Work vs home resolve www.mathworks.com to different akamaiedge.net servers because work's internet cross-connection is in a different city.
Walter Roberson
Walter Roberson on 23 Jun 2012
I was getting nasty problems with pages not responding just a moment ago. I switch from Firefox to Safari and matters got much much better. Not completely perfect, but a huge difference.
I had restarted Firefox (and even my computer) along the way, but that did not help.
It is possible that one of my browser add-ons was causing problems (but only on this site??). I have not experimented with enabling them selectively.

Sign in to comment.


Image Analyst
Image Analyst on 18 May 2012
I have never noticed any latency issue at all. I use Firefox and Windows 7.

  2 Comments

Image Analyst
Image Analyst on 11 Nov 2017
Now I am. Both on my home computer and work computer. And not just in Answers but in any page where there is an edit field that you type in. There was a java update a few days ago right around when this started. I wonder if it's related. Very annoying. Now there is like a 2 - 10 second lag from typing to seeing the letters. And persists after rebooting and on multiple computers and multiple web sites.
Jan
Jan on 11 Nov 2017
I have disabled Java in the web browsers for security reasons and block some sites for Java script, e.g. on adobetm.com, but allowed mathworks.com. I do no see any lag currently under Firefox 56/64bit and Windows 7.

Sign in to comment.


Jan
Jan on 11 Jun 2012
Another latency problem: When I click on the "Comment this Question" button or the corresponding [Save] button, I have to wait 5 to 10 seconds until the action happens. This feels unresponsive.
I do not assume that reporting such problems is useful, because this forum is obviously not maintained anymore.

  2 Comments

Greg Heath
Greg Heath on 13 Jun 2012
In addition to the latency, several times I have lost large unfinished posts by accidentally hitting a wrong key. For both reasons I have resorted to cutting and pasting from the MATLAB editor some time ago.
Jan
Jan on 13 Jun 2012
@Greg and Lucas: You and others create and edit messages in the editor or even in Word. This is a damning indictment of the usability of the interface.

Sign in to comment.


Jan
Jan on 8 May 2019
And a new update: Today the characters appear around 1 second after I've type them. During standard typing this is more or less inconvenient, but for editing, e.g. pressing backspace until a word is deleted, this has a very low usability.
Win7/64, Firefox.

  0 Comments

Sign in to comment.

Sign in to answer this question.


Translated by