Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Preferencias de guía

Establezca preferencias

Puede establecer las preferencias de GUIDE. En la pestaña, en la sección, haga clic en.MATLAB®HomeEnvironmentPreferences Estas preferencias se aplican a GUIDE y a todas las UIs que cree.

Las preferencias se encuentran en diferentes ubicaciones dentro del cuadro de diálogo Preferencias:

Preferencias de confirmación

GUIDE proporciona dos preferencias de confirmación. Puede elegir si desea mostrar un cuadro de diálogo de confirmación cuando

  • Active una interfaz de usuario de GUIDE.

  • Exporte una IU desde GUIDE.

  • Cambiar una firma de devolución de llamada generada por GUIDE.

En el cuadro de diálogo Preferencias, haga clic en MATLAB > General > Confirmation Dialogs para acceder a las preferencias de confirmación de GUIDE. Busque la palabra en la columna.GUIDETool

Preguntar para guardar en activar

Al activar una interfaz de usuario desde el editor de diseño, haga clic en el botónRun , un cuadro de diálogo le informa del guardado inminente y le permite elegir si desea continuar o no.

Preguntar a guardar en exportar

Desde el editor de diseño, al seleccionar File > Export to MATLAB-file, un cuadro de diálogo le informa del guardado inminente y le permite elegir si desea continuar o no.

Preferencia de compatibilidad con versiones anteriores

Compatibilidad con la versión 5 o posteriorMATLAB

Los archivos FIG de interfaz de usuario creados o modificados con 7,0 o una versión posterior no son automáticamente compatibles con la versión 6,5 y versiones anteriores.MATLAB GUIDE genera automáticamente los archivos FIG, que son archivos binarios que contienen la información de diseño de la interfaz de usuario.

Para hacer que un archivo FIG sea compatible con versiones anteriores, desde el editor de diseño, seleccione File > Preferences > General > MAT-Filesy, a continuación, seleccione.MATLAB Version 5 or later (save -v6)

Nota

La opción que se describe en esta sección es obsoleta y se eliminará en una versión futura de.-v6MATLAB

Todas las demás preferencias

GUIDE proporciona otras preferencias, para la interfaz del editor de diseño y para insertar comentarios de código. En el cuadro de diálogo Preferencias, haga clic para acceder a estas preferencias.GUIDE

En los temas siguientes se describen las preferencias de este cuadro de diálogo:

Mostrar nombres en la paleta de componentes

Muestra los iconos y los nombres en la paleta de componentes, como se muestra a continuación. Cuando se desactiva, los iconos solo se muestran en dos columnas, con información sobre herramientas.

Mostrar extensión de archivo en el título de la ventana

Muestra el nombre de archivo FIG-file con su extensión de archivo, en el título de la ventana Editor de diseño..fig Si está desactivada, solo se muestra el nombre de archivo.

Mostrar ruta de archivo en título de ventana

Muestra la ruta completa del archivo en el título de la ventana Editor de diseño. Si está desactivada, la ruta del archivo no se muestra.

Agregar comentarios para funciones de devolución de llamada recién generadas

Las devoluciones de llamada son bloques de código que se ejecutan en respuesta a las acciones del usuario, como hacer clic en los botones o manipular los reguladores. De forma predeterminada, GUIDE configura plantillas que declaran devoluciones de llamada como funciones y agrega comentarios al principio de cada una. La mayoría de los comentarios son similares a los siguientes.

% --- Executes during object deletion, before destroying properties. function figure1_DeleteFcn(hObject, eventdata, handles) % hObject    handle to figure1 (see GCBO) % eventdata  reserved - to be defined in a future version of MATLAB % handles    structure with handles and user data (see GUIDATA)

Algunas devoluciones de llamada se agregan automáticamente porque sus componentes asociados forman parte de la plantilla GUIDE original que eligió. Otras devoluciones de llamada usadas habitualmente se agregan automáticamente al agregar componentes. También puede Agregar devoluciones llamada explícitamente seleccionándolos desde View > View Callbacks menú o en el menú contextual del componente.

Si anula la selección de esta preferencia, GUIDE incluye comentarios solo para las devoluciones de llamada que se incluyen automáticamente para admitir la plantilla GUIDE original. GUIDE no incluye comentarios para las devoluciones de llamada añadidas posteriormente al código.

Consulte para obtener más información acerca de las devoluciones de llamada y sobre los argumentos descritos en los comentarios anteriores.Escriba callbacks en GUIDE

Mostrar panel de mensaje del diseñador de aplicaciones

Muestra el panel de mensajes del diseñador de aplicaciones en el editor de diseño GUIDE. El diseñador de aplicaciones es el entorno recomendado para crear apps.MATLAB El panel de mensajes proporciona vínculos y herramientas para ayudarle a obtener más información sobre el diseñador de aplicaciones.

Desde el panel se puede:

  • Vea una visión general de 5 minutos del entorno de desarrollo de App Designer.

  • Obtenga más información sobre las diferencias de características entre GUIDE y app Designer.

  • Abra el diseñador de aplicaciones.

  • Migre la aplicación GUIDE existente a App Designer mediante la herramienta de migración GUIDE to App Designer.

Cuando se borra esta preferencia, el panel de mensajes no aparece en el editor de diseño.

Temas relacionados