Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Copiar una figura en el portapapeles desde el menú Editar

Este ejemplo muestra cómo copiar una figura en el portapapeles y la manera de configurar las opciones de copia. Cuando una figura está en el portapapeles, puede pegarla en otras aplicaciones, como en un documento o presentación.

Copiar figura en el portapapeles

Cree una gráfica de barras con un título. Copie la figura en su portapapeles del sistema haciendo clic en Edit > Copy Figure.

x = [3 5 2 6 1 8 2 3];
bar(x)
title('Bar Chart')

Pegue la figura copiada en otras aplicaciones, típicamente haciendo clic con el botón derecho. De manera predeterminada, MATLAB® convierte el color de fondo de la figura copiada en blanco.

Nota

La opción Copy Figure no está disponible en los sistemas Linux®. Utilice la alternativa programática.

Para copiar la figura de manera programática, utilice la opción '-clipboard' con print. Especifique el formato como '-dbitmap', '-dpdf' o '-dmeta'. El formato de metarchivo, '-dmeta', solo se admite en los sistemas Windows®.

Especificar opciones de formato, color de fondo y tamaño

Puede ajustar determinadas configuraciones para las figuras que se copian en el portapapeles. Acceda a estas opciones seleccionando Edit > Copy Options en el menú de la figura. Las configuraciones se aplican a todas las próximas figuras copiadas en el portapapeles. No afectan al aspecto de la figura en la pantalla.

Nota

Esta ventana solo está disponible en los sistemas Windows. En sistemas Mac y Linux, utilice las alternativas programáticas.

Establezca el formato del portapapeles en una de estas opciones:

  • Metarchivo: copia la figura en un formato de vector de color de EMF.

  • Conservar información: seleccione el formato basado en el renderizador de la figura. Si el renderizador es painters, el formato es un metarchivo. Si el renderizador es OpenGL®, el formato es una imagen de mapa de bits.

  • Mapa de bits: copie la figura en un formato de mapa de bits.

Configure el color de fondo de la figura mediante una de estas opciones:

  • Utilizar color de la figura: mantiene el color de fondo igual que como aparece en la pantalla. Para utilizar la alternativa programática, configure la propiedad InvertHardcopy para la figura en 'off' antes de copiar.

  • Forzar fondo blanco: copia la figura con un fondo blanco. Para utilizar la alternativa programática, configure la propiedad InvertHardcopy para la figura en 'on' antes de copiar.

  • Fondo transparente: copie la figura con un fondo transparente. Para utilizar la alternativa programática, configure la propiedad Color para la figura en 'none' y la propiedad InvertHardcopy en 'off' antes de copiar. Los formatos PDF y metarchivo admiten la transparencia. Los formatos de mapa de bits no admiten la transparencia.

Copie la figura con el mismo tamaño con el que aparece en la pantalla seleccionando Match figure screen size. Desactive esta opción para utilizar el ancho y la altura especificados en el cuadro de diálogo Configuración de exportación.

Consulte también

|

Temas relacionados