Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Requisitos del sistema para la API del motor paraMATLABPython

Puede utilizar la API del motor para cualquier plataforma que admita.MATLAB®Python®MATLAB

Compatibilidad con versionesPython

Para utilizar la API del motor para, debe tener una versión admitida de la implementación de referencia (también conocida como CPython) instalada en el sistema.MATLABPythonPython El motor es compatible con las siguientes versiones:

  • versión 2,7

  • versión 3,5

  • versión 3,6

  • versión 3,7

Para descargar e instalar, consulte.PythonInstalar implementación admitidaPython

Nota

Para los sistemas de 64 bits, seleccione la versión de 64 bits, llamada instalador MSI x86-64.MATLABMicrosoft®Windows®PythonWindows

Para llamar desde el símbolo del sistema operativo, realice una de las siguientes acciones.Python

  • Agregue la ruta de acceso completa a la variable de entorno PATHPython

  • Incluya la ruta completa cuando llame al intérpretePython

Para determinar si está llamando a una versión compatible, escriba en el símbolo del sistema operativo para mostrar el número de versión.python -VPython

Para obtener ayuda sobre el idioma, consultePython www.python.org/doc en la documentación.python.org Para obtener ayuda sobre los módulos de terceros o definidos por el usuario, consulte la documentación del producto.

Descargar versiones de 64 bits de yPythonMATLAB

La arquitectura de debe coincidir con la arquitectura de.MATLABPython En el sitio de descarga, las descargas para plataformas son versiones de 32 bits de forma predeterminada.PythonMicrosoftWindows Para descargar la versión de 64 bits, elija las opciones con el nombre.Windows x86-64 MSI installer

Para comprobar si su versión es de 32 bits o de 64 bits, escriba el siguiente código en el símbolo del sistema:PythonPython

import sys print(sys.maxsize > 2**32) 

Este código devuelve si el intérprete es de 64 bits y si es de 32 bits.TruePythonFalse (Para obtener más información, consulte.)Documentación de Python 2,7 — multiplataforma

Requisitos para la creación de origenPython

Para habilitar la compatibilidad con Unicode ancho para 2,7, configure la compilación con la opción.PythonLinux®--enable-unicode=ucs4 Esta opción de configuración no es necesaria cuando se compila cualquier versión de sistemas Mac o 3. x.PythonPythonLinux

Temas relacionados

Sitios web externos