Borrar filtros
Borrar filtros

Mass balance issues with PBPK model in Simbiology

3 visualizaciones (últimos 30 días)
Andrew Heitman
Andrew Heitman el 3 de Oct. de 2019
Comentada: Andrew Heitman el 4 de Oct. de 2019
I am having issues with mass balance (creating mass out of nowhere, Nobel prize here I come...) in my PBPK model. Eventually the system evens out, but the first steps (hours 0-10 out of 72) end up spitting out about a 1-10% error as a fraction of the dose applied. I have tried different solvers and this has not eliminated the issue. The mass balance term is sensitive to parameter values as well.
Any pointers would help.

Respuesta aceptada

Arthur Goldsipe
Arthur Goldsipe el 4 de Oct. de 2019
One way to confirm that that your model structure is correct is to use SimBiology sbioconsmoiety function to identify conserved moieties. You can read more about it here. If you haven't already, you will want to explicitly add species to your model to explicitly track any eliminated species.
If you suspect that your errors are due to integration tolerance issues, you might also try changing settings related to absolute tolerance scaling (which is described in more detail here). Specifically, I would first try turning off automatic scaling, and next try turning it back on and adjusting the value of AbsoluteToleranceStepSize. While this automatic scaling feature helps for most models, when it does cause problems it tends to be due to early time steps when a species starts out at 0 and changes extremely rapidly. Decreasing the time scale of this step size can help SimBiology better determine the magnitude of such rapid changes.
-Arthur
  1 comentario
Andrew Heitman
Andrew Heitman el 4 de Oct. de 2019
I turned off automatic scaling and that resolved the mass balance issue. Additionally, when I set the initial "dose" species to my desired dose instead of using dosing function - the accuracy improved.
This answer was very helpful.

Iniciar sesión para comentar.

Más respuestas (2)

Sietse Braakman
Sietse Braakman el 3 de Oct. de 2019
Hi Andrew,
This might be an integration imprecision in the solver due to tolerances that are not strict enough. Have you tried tightening your absolute and relative tolerance and seeing whether this reduces the mass balance error you are observing?
Best,
Sietse

Andrew Heitman
Andrew Heitman el 3 de Oct. de 2019
I did, I tightened up the tolerances and it didnt have a major effect. I can try to increase the tolerance some more

Comunidades de usuarios

Más respuestas en  SimBiology Community

Categorías

Más información sobre Scan Parameter Ranges en Help Center y File Exchange.

Productos


Versión

R2018b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by