Main Content

Esta página aún no se ha traducido para esta versión. Puede ver la versión más reciente de esta página en inglés.

Introducción al Diseñador de filtros

Para abrir la aplicación, escriba en el símbolo del sistema.Diseñador de filtros

filterDesigner
MATLAB®

La aplicación se abre con el panel Filtro de diseño mostrado.Diseñador de filtros

Tenga en cuenta que al abrir , no está habilitado.Diseñador de filtrosDesign Filter Usted debe hacer un cambio al diseño predeterminado del filtro para habilitar.Design Filter Esto es cierto cada vez que desea cambiar el diseño del filtro. Cambios en los elementos de los botones de opción o en los elementos del menú desplegable, como los que están debajo o habiliten inmediatamente. Response TypeFilter OrderDesign Filter Cambios en las especificaciones de cuadros de texto como , , y requiere que haga clic fuera del cuadro de texto para habilitar .FsFpassFstopDesign Filter

Elegir un tipo de respuesta

Puede elegir entre varios tipos de respuesta:

  • Pasabajos

  • Coseno elevado

  • Pasa-altos

  • Bandpass

  • Bandstop

  • Diferenciador

  • Multibanda

  • Transformador Hilbert

  • Magnitud arbitraria

Los tipos de respuesta adicionales están disponibles si tiene software instalado.DSP System Toolbox™

Nota

No todos los métodos de diseño de filtro están disponibles para todos los tipos de respuesta. Una vez que elija el tipo de respuesta, esto puede restringir los métodos de diseño de filtro disponibles para usted. Los métodos de diseño de filtro que no están disponibles para un tipo de respuesta seleccionado se quitan de la región Método de diseño de la aplicación.

Elegir un método de diseño de filtro

Puede usar el método de diseño de filtro predeterminado para el tipo de respuesta que ha seleccionado, o puede seleccionar un método de diseño de filtro de los métodos FIR e IIR disponibles enumerados en la aplicación.

Para seleccionar el algoritmo Remez para calcular los coeficientes de filtro FIR, seleccione el botón de opción y elija de la lista de métodos.FIREquiripple

Configuración de las especificaciones de diseño del filtro

Visualización de especificaciones del filtro

Las especificaciones de diseño del filtro que puede establecer varían según el tipo de respuesta y el método de diseño. La región de visualización ilustra las especificaciones del filtro al seleccionar Analysis > Filter Specifications o al hacer clic en el botón de la barra de herramientas.Filter Specifications

También puede ver las especificaciones del filtro en la gráfica Magnitud de un filtro diseñado seleccionando View > Specification Mask.

Orden de filtro

Tiene dos opciones mutuamente excluyentes para determinar el orden del filtro al diseñar un filtro equisiosiosio:

  • :Specify order Introduzca el orden de filtro en un cuadro de texto.

  • :Minimum order El método de diseño de filtro determina el filtro de orden mínimo.

Tenga en cuenta que las opciones de especificación de orden de filtro dependen del método de diseño de filtro que elija. Es posible que algunos métodos de filtro no tengan ambas opciones disponibles.

Opciones

Las opciones disponibles dependen del método de diseño del filtro seleccionado. Solo los métodos de diseño FIR Equiripple y FIR Window tienen opciones configurables. Para FIR Equiripple, la opción es un archivo .Density Factor Consulte para obtener más información.firpm Para la ventana FIR las opciones son , selección, y para las siguientes ventanas, un parámetro configurable:Scale PassbandWindow

Ventana

Parámetro

Chebyshev ( )chebwin

Atenuación de Sidelobe

Gaussiano ( )gausswin

Alfa

Kaiser ( )kaiser

Beta

Taylor ( )taylorwin

Nivel de Nbar y Sidelobe

Tukey ( )tukeywin

Alfa

Definido por el usuario

Nombre de la función, parámetro

Puede ver la ventana en la Herramienta de visualización de ventanas ( ) haciendo clic en el botón.wvtoolView

Especificaciones de frecuencia del filtro de paso de banda

Para un filtro de paso de banda, puede establecer

  • Unidades de frecuencia:

    • Hz

    • Khz

    • Mhz

    • Normalizado (0 a 1)

  • Frecuencia de muestreo

  • Frecuencias de banda de paso

  • Frecuencias de banda de parada

Especifique la banda de paso con dos frecuencias. La primera frecuencia determina el borde inferior de la banda de paso, y la segunda frecuencia determina el borde superior de la banda de paso.

Del mismo modo, se especifica la banda de parada con dos frecuencias. La primera frecuencia determina el borde superior de la primera banda de parada, y la segunda frecuencia determina el borde inferior de la segunda banda de parada.

Especificaciones de magnitud del filtro de paso de banda

Para un filtro de paso de banda, puede especificar las siguientes características de respuesta de magnitud:

  • Unidades para la respuesta de magnitud (dB o lineal)

  • Ondulación de banda de paso

  • Atenuación de la banda de parada

Computar los coeficientes de filtro

Ahora que ha especificado el diseño del filtro, haga clic en el botón para calcular los coeficientes de filtro.Design Filter

Nota

El botón se desactiva una vez que haya calculado los coeficientes para el diseño del filtro.Design Filter Este botón se habilita de nuevo una vez que realice cambios en las especificaciones del filtro.

Análisis del filtro

Visualización de respuestas de filtro

Puede ver las siguientes características de respuesta de filtro en la región de visualización o en una ventana independiente.

  • Respuesta de magnitud

  • Respuesta de fase

  • Respuestas de magnitud y fase

  • Respuesta de retraso del grupo

  • Respuesta de retardo de fase

  • Respuesta de impulso

  • Respuesta escalonada

  • Parcela Polo-cero

  • Respuesta de fase cero: disponible en el menú contextual del eje en una gráfica de respuesta Magnitud o Magnitud y Fase.y

Nota

Si tiene el producto instalado, hay otros dos análisis disponibles: estimación de la respuesta de magnitud y potencia de ruido de redondeo.DSP System Toolbox Estos dos análisis son los únicos que utilizan filtros internos.

Para obtener descripciones de las respuestas anteriores y sus botones de barra de herramientas asociados y otros botones de la barra de herramientas, consulte .Diseñador de filtrosFVTool

Puede visualizar dos respuestas en el mismo trazado seleccionando Analysis > Overlay Analysis y seleccionar una respuesta disponible. Se agrega un segundo eje al lado derecho de la gráfica de respuesta.y (Tenga en cuenta que no todas las respuestas se pueden superponer entre sí.)

También puede mostrar los coeficientes de filtro y la información detallada del filtro en esta región.

Para todos los métodos de análisis, excepto la respuesta de fase cero, puede acceder a ellos desde el menú, el cuadro de diálogo Parámetros de análisis desde el menú contextual o mediante los botones de la barra de herramientas.Analysis Para la fase cero, haga clic con el botón derecho en el eje del trazado y seleccione en el menú contextual.yZero-phase

Puede superponer las especificaciones del filtro en el trazado Magnitud seleccionando View > Specification Mask.

Uso de consejos de datos

Puede hacer clic en la respuesta para agregar sugerencias de datos de trazado que muestren información sobre puntos concretos en la respuesta.

Para obtener información sobre el uso de sugerencias de datos, consulte .Explorar de forma interactiva los datos representados

Dibujo Máscaras Espectrales

Para añadir máscaras espectrales o líneas de área de rechazo a la gráfica de magnitud, haga clic en View > User-defined Spectral Mask.

La máscara se define mediante un vector de frecuencia y un vector de magnitud. Estos vectores deben tener la misma longitud.

  • — Seleccione esta opción para activar la visualización de la máscara.Enable Mask

  • — Seleccione esta opción para normalizar la frecuencia entre 0 y 1 en el rango de frecuencia mostrado.Normalized Frequency

  • — Introduzca un vector de valores de frecuencia de eje.Frequency Vectorx

  • — Seleccione las unidades de magnitud deseadas.Magnitude Units Estas unidades deben coincidir con las unidades utilizadas en la gráfica de magnitud.

  • — Introduzca un vector de valores de magnitud del eje.Magnitude Vectory

Cambio de la frecuencia de muestreo

Para cambiar la frecuencia de muestreo del filtro, haga clic con el botón derecho en cualquier trazado de respuesta de filtro y seleccione en el menú contextual.Sampling Frequency

Para cambiar el nombre del filtro, escriba el nuevo nombre en .Filter name (En , si tiene varios filtros, seleccione el filtro deseado y, a continuación, escriba el nuevo nombre.)FVTool

Para cambiar la frecuencia de muestreo, seleccione la unidad deseada e introduzca la frecuencia de muestreo en .UnitsFs (Para cada filtro en , puede especificar una frecuencia de muestreo diferente o puede aplicar la frecuencia de muestreo a todos los filtros.)fvtool

Para guardar los parámetros mostrados como los valores predeterminados que se utilizarán cuando o FVTool se abre, haga clic en .Diseñador de filtrosSave as Default

Para restaurar los valores predeterminados, haga clic en .Restore Original Defaults

Visualización de la respuesta en FVTool

Para visualizar las características de respuesta del filtro en una ventana independiente, seleccione View > Filter Visualization Tool (disponible si hay algún análisis, excepto las especificaciones del filtro, en la región de visualización) o haga clic en el botón.Full View Analysis Esto inicia la herramienta de visualización de filtros ( ).fvtool

Nota

Si las especificaciones de filtro se muestran en la región de visualización, al hacer clic en el botón de la barra de herramientas se inicia una ventana de figura en lugar de FVTool.Full View AnalysisMATLAB El elemento de menú asociado es , que solo está habilitado si se muestran las especificaciones del filtro.Print to Figure

Puede utilizar esta herramienta para anotar el diseño, ver otras características del filtro e imprimir la respuesta del filtro. Puede vincular y FVTool para que los cambios realizados en se reflejen inmediatamente en FVTool.Diseñador de filtrosDiseñador de filtros Consulte para obtener más información.FVTool

Edición del filtro mediante el editor Polo/Cero

Visualización de la gráfica Polo-Cero

Puede editar los coeficientes de un filtro diseñado o importado moviendo, eliminando o añadiendo polos y/o ceros mediante el panel Editor de polo/cero.

Nota

No se puede generar código (MATLABFile > Generate MATLAB code) si el filtro se ha diseñado o editado con el Editor Polo/Cero.

No se pueden mover polos y ceros cuantificados. Sólo puede mover los polos y ceros de referencia.

Haga clic en el botón de la barra lateral o seleccionePole/Zero Editor Edit > Pole/Zero Editor para mostrar el panel Editor de polo/cero.

Los polos se muestran utilizando símbolos x y los ceros se muestran utilizando símbolos o.

Cambio de la gráfica Polo-Cero

Los botones del modo de trazado se encuentran a la izquierda del trazado polo/cero. Seleccione uno de los botones para cambiar el modo del trazado polo/cero. El Editor Polo/Cero tiene estos botones de izquierda a derecha: , , , y .Move Pole/ZeroAdd PoleAdd ZeroDelete Pole/Zero

Los siguientes parámetros y controles de trazado se encuentran a la izquierda del trazado polo/cero y debajo de los botones del modo de trazado.

  • — factor para compensar las ganancias de los polos y ceros del filtroFilter gain

  • — unidades ( o ) del polo seleccionado o ceroCoordinatesPolarRectangular

  • — si se seleccionan coordenadas polares, la magnitud del polo seleccionado o ceroMagnitude

  • — si se seleccionan coordenadas polares, el ángulo de los polos seleccionados o los cerosAngle

  • — si se seleccionan coordenadas rectangulares, componente real de los polos seleccionados o cero(s)Real

  • — si se seleccionan coordenadas rectangulares, componente imaginario del polo seleccionado o ceroImaginary

  • — para filtros multisección, número de la sección actualSection

  • : crea un poste conjugado correspondiente o cero o selecciona automáticamente el poste conjugado o cero si ya existe.Conjugate

  • : actualiza inmediatamente la respuesta de magnitud mostrada cuando se añaden, mueven o eliminan polos o ceros.Auto update

el Edit > Pole/Zero Editor tiene elementos para seleccionar múltiples polos/ceros, para invertir y espejar polos/ceros, y para eliminar, escalar y rotar polos/ceros.

  • Al seleccionar un polo o cero de un par conjugado, la casilla de verificación y el conjugado se seleccionan automáticamente.Conjugate

Conversión de la estructura del filtro

Convertir en una nueva estructura

Puede usar Edit > Convert Structure para convertir el filtro actual en una nueva estructura. Todos los filtros se pueden convertir en las siguientes representaciones:

  • Forma directa I

  • Forma directa II

  • Forma directa que transecé

  • Forma directa II transpuesta

  • Lattice ARMA

Nota

Si tiene el producto instalado, verá estructuras adicionales en el cuadro de diálogo Convertir estructura.DSP System Toolbox

Además, están disponibles las siguientes conversiones para determinadas clases de filtros:

  • Los filtros FIR de fase mínima se pueden convertir en fase mínima de celosía

  • Los filtros FIR de fase máxima se pueden convertir en fase máxima de celosía

  • Los filtros Allpass se pueden convertir en Lattice allpass

  • Los filtros IIR se pueden convertir a Lattice ARMA

Nota

Conversión de un filtro estructura a otra puede producir un resultado con características diferentes a la original. Esto se debe a la aritmética de precisión finita del ordenador y a las variaciones en los cálculos de redondeo de la conversión.

Por ejemplo:

  • Seleccione Edit > Convert Structure para abrir el cuadro de diálogo Convertir estructura.

  • Seleccione en la lista de estructuras de filtro.Direct-formI

Conversión a secciones de segundo orden

Puede usar Edit > Convert to Second-Order Sections para almacenar la estructura de filtro convertida como una colección de secciones de segundo orden en lugar de como una estructura monolítica de orden superior.

Nota

Las siguientes opciones también se utilizan para Edit > Reorder and Scale Second-Order Sections, que se utiliza para modificar una estructura de filtro SOS.

Las siguientes opciones solo están disponibles al convertir una estructura de forma directa II:Scale

  • (predeterminado)None

  • (L-2L2 norma)

  • (L-infinityL norma)

El ( o ) determina el orden de las secciones de segundo orden.DirectionUpDown El orden óptimo cambia en función de la opción seleccionada.Scale

Por ejemplo:

  • Seleccione Edit > Convert to Second-Order Sections para abrir el cuadro de diálogo Convertir en SOS.

  • Seleccione en el menú paraL-infinityScaleL escalado de normas.

  • Dejar como la opción.UpDirection

Nota

Para convertir de secciones de segundo orden en una sola sección, utilice Edit > Convert to Single Section.

Exportación de un diseño de filtro

Exportación de coeficientes u objetos al espacio de trabajo

Puede guardar el filtro como variables de coeficientes de filtro o como una variable de objeto de filtro. Para guardar el filtro en el espacio de trabajo:MATLAB

  1. Seleccione File > Export. Aparece el cuadro de diálogo Exportar.

  2. Seleccione en el menú.WorkspaceExport To

  3. Seleccione en el menú para guardar los coeficientes de filtro o seleccione guardar el filtro en un objeto de filtro.CoefficientsExport AsObjects

  4. Para los coeficientes, asigne nombres de variables utilizando los cuadros de texto (para filtros FIR) o (para filtros IIR), o (para filtros IIR en formato de sección de segundo orden) en la región Nombres de variables.NumeratorNumeratorDenominatorSOS MatrixScale Values

    Para los objetos, asigne el nombre de la variable en el cuadro de texto.Discrete Filter Si tiene variables con los mismos nombres en el área de trabajo y desea sobrescribirlas, active la casilla de verificación.Overwrite Variables

  5. Haga clic en el botón.Export

Exportación de coeficientes a un archivo ASCII

Para guardar coeficientes de filtro en un archivo de texto,

  1. Seleccione File > Export. Aparece el cuadro de diálogo Exportar.

  2. Seleccione en el menú.CoefficientsFile(ASCII)Export To

  3. Haga clic en el botón.Export Los coeficientes de filtro de exportación a . Aparece el cuadro de diálogo Archivo FCF.

  4. Elija o introduzca un nombre de archivo y haga clic en el botón.Save

Los coeficientes se guardan en el archivo de texto especificado y el Editor se abre para mostrar el archivo.MATLAB El archivo de texto también contiene comentarios con el número de versión, el número de versión y la información de filtro.MATLABSignal Processing Toolbox™

Exportación de coeficientes u objetos a un archivo MAT

Para guardar coeficientes de filtro o un objeto de filtro como variables en un archivo MAT:

  1. Seleccione File > Export. Aparece el cuadro de diálogo Exportar.

  2. Seleccione en el menú.MAT-fileExport To

  3. Seleccione en el menú para guardar los coeficientes de filtro o seleccione guardar el filtro en un objeto de filtro.CoefficientsExport AsObjects

  4. Para los coeficientes, asigne nombres de variables utilizando los cuadros de texto (para filtros FIR) o (para filtros IIR), o (para filtros IIR en formato de sección de segundo orden) en la región Nombres de variables.NumeratorNumeratorDenominatorSOS MatrixScale Values

    Para los objetos, asigne el nombre de la variable en el cuadro de texto o.Discrete Filter (Quantized Filter) Si tiene variables con los mismos nombres en el área de trabajo y desea sobrescribirlas, active la casilla de verificación.Overwrite Variables

  5. Haga clic en el botón.Export Aparece el cuadro de diálogo Exportar a un archivo MAT.

  6. Elija o introduzca un nombre de archivo y haga clic en el botón.Save

Exportación a un modeloSimulink

Si tiene el producto instalado, puede exportar un bloque del diseño del filtro e insertarlo en un modelo nuevo o existente.Simulink®SimulinkSimulink

Puede exportar un filtro diseñado utilizando cualquier método de diseño de filtro disponible en .Diseñador de filtros

Nota

Si tiene el e instalado, puede exportar un filtro CIC a un modelo.DSP System ToolboxFixed-Point Designer™Simulink

  1. Después de diseñar el filtro, haga clic en el botón de la barra lateral o seleccioneRealize Model File > Export to Simulink Model. Se muestra el panel Realizar modelo.

  2. Especifique el nombre que se utilizará para el bloque en .Block name

  3. Para insertar el bloque en el modelo actual (más recientemente seleccionado), establezca elSimulinkDestination Current. Para inserción del bloque en un nuevo modelo, seleccione New. Para insertar el bloque en un subsistema definido por el usuario, seleccione User defined.

  4. Si desea sobrescribir un bloque creado previamente desde este panel, active .Overwrite generated `Filter' block

  5. Si selecciona la casilla de verificación, el filtro se crea como un bloque, que utiliza subelementos independientes.Build model using basic elementsSubsistema (Simulink) En este modo, están disponibles las siguientes optimizaciones:

    • Optimize for zero gains : elimina las rutas de ganancia de valor cero de la estructura del filtro.

    • Optimize for unity gains — Sustituye un cable (cortocircuito) por ganancias iguales a 1 en la estructura del filtro.

    • Optimize for negative gains — Sustituye un cable (circuito corto) por ganancias iguales a -1 y cambia las adiciones correspondientes a las restas en la estructura del filtro.

    • Optimize delay chains — Sustituye las cadenas de retardo compuestas por retrasos en las unidades con un único retraso de .nn

    • Optimize for unity scale values : elimina las multiplicaciones de valores de escala iguales a 1 de la estructura del filtro.

    La siguiente ilustración muestra los efectos de algunas de las optimizaciones:

    Nota

    La casilla de verificación solo está habilitada cuando tiene una licencia y el filtro se puede diseñar mediante un bloque o un bloque.Build model using basic elementsDSP System ToolboxBiquad Filter (DSP System Toolbox)Discrete FIR Filter (Simulink) Para obtener más información, consulte el tema de la documentación.Filter Realization Wizard (DSP System Toolbox)DSP System Toolbox

  6. Establezca el parámetro para especificar si el filtro generado realiza un procesamiento basado en muestras o fotogramas en la entrada.Input processing Dependiendo del tipo de filtro que diseñe, puede estar disponible una o ambas de las siguientes opciones:

    • Columns as channels (frame based) — Al seleccionar esta opción, el bloque trata cada columna de la entrada como un canal independiente.

    • Elements as channels (sample based) — Al seleccionar esta opción, el bloque trata cada elemento de la entrada como un canal independiente.

  7. Haga clic en el botón para crear el bloque de filtro.Realize Model Cuando se selecciona la casilla de verificación, implementa el filtro como un bloque de subsistema mediante , , y bloquea.Build model using basic elementsDiseñador de filtrosSum (Simulink)Gain (Simulink)Retraso (Simulink)

Si hace doble clic en el bloque Filtro, se muestra la estructura del filtro.Simulink

Generación de un archivo de encabezado C

Es posible que desee incluir información de filtro en un programa C externo. Para crear un archivo de encabezado C con variables que contienen datos de parámetros de filtro, siga este procedimiento:

  1. Seleccione Targets > Generate C Header. Aparece el cuadro de diálogo Generar encabezado C.

  2. Introduzca los nombres de las variables que se utilizarán en el archivo de encabezado C. La estructura de filtro concreta determina las variables que se crean en el archivo.

    Estructura del filtro

    Parámetro variable

    Forma directa I

    Forma directa II

    Forma directa que transecé

    Forma directa II transpuesta

    , , ,NumeratorNumerator lengthDenominatorDenominator length

    Lattice ARMA

    , , ,Lattice coeff.Lattice coeff. lengthLadder coeff.Ladder coeff. length

    Lattice MA

    , , y (inactivo si el filtro solo tiene una sección)Lattice coeff.Lattice coeff. lengthNumber of sections

    Fir de forma directa transpuesto

    , , y (inactivo si el filtro solo tiene una sección)NumeratorNumerator lengthNumber of sections

    Las variables de longitud contienen el número total de coeficientes de ese tipo.

    Nota

    Los nombres de las variables no pueden ser palabras reservadas en el lenguaje C, como "for."

  3. Seleccione esta opción para utilizar el tipo de datos sugerido o seleccione y seleccione el tipo de datos deseado en el menú desplegable.Export SuggestedExport As

    Nota

    Si no tiene instalado software, al seleccionar cualquier tipo de datos que no sea de punto flotante de doble precisión, se obtiene un filtro que no coincide exactamente con el que ha diseñado en el archivo .DSP System ToolboxDiseñador de filtros Esto se debe al redondeo y truncamiento de las diferencias.

  4. Haga clic para guardar el archivo y dejar el cuadro de diálogo abierto para definiciones de archivo de encabezado C adicionales.Generate Para cerrar el cuadro de diálogo, haga clic en .Close

Generar códigoMATLAB

Puede generar código que construya el filtro que diseñó desde la línea de comandos.MATLABDiseñador de filtros Seleccione File > Generate MATLAB Code > Filter Design Function y especifique el nombre de archivo en el cuadro de diálogo Generar código.MATLAB

Nota

No se puede generar código (MATLABFile > Generate MATLAB Code > Filter Design Function) si el filtro se ha diseñado o editado con el Editor Polo/Cero.

El siguiente es código generado para el filtro de paso bajo predeterminado en .MATLABDiseñador de filtros

function Hd = ExFilter %EXFILTER Returns a discrete-time filter object.  % % MATLAB Code % Generated by MATLAB(R) 7.11 and the Signal Processing Toolbox 6.14. % % Generated on: 17-Feb-2010 14:15:37 %  % Equiripple Lowpass filter designed using the FIRPM function.  % All frequency values are in Hz. Fs = 48000;  % Sampling Frequency  Fpass = 9600;            % Passband Frequency Fstop = 12000;           % Stopband Frequency Dpass = 0.057501127785;  % Passband Ripple Dstop = 0.0001;          % Stopband Attenuation dens  = 20;              % Density Factor  % Calculate the order from the parameters using FIRPMORD. [N, Fo, Ao, W] = firpmord([Fpass, Fstop]/(Fs/2), [1 0], [Dpass, Dstop]);  % Calculate the coefficients using the FIRPM function. b  = firpm(N, Fo, Ao, W, {dens}); Hd = dfilt.dffir(b);  % [EOF] 

Administración de filtros en la sesión actual

Puede almacenar filtros diseñados en la sesión actual para conectarse en cascada, exportar a FVTool o para volver a llamar más tarde en las mismas sesiones o en futuras.Diseñador de filtrosDiseñador de filtros

Almacene y acceda a los filtros guardados con los botones y, respectivamente, en el panel.Store FilterFilter ManagerCurrent Filter Information

: muestra el cuadro de diálogo Filtro de tienda en el que se especifica el nombre del filtro que se utilizará al almacenar el filtro en el Administrador de filtros.Store Filter El nombre predeterminado es el tipo del filtro.

: abre el Administrador de filtros.Filter Manager

El filtro actual se muestra debajo del cuadro de lista. Para cambiar el filtro actual, resalte el filtro deseado. Si selecciona , muestra las especificaciones de filtro seleccionadas actualmente.Edit current filterDiseñador de filtros Si realiza algún cambio en las especificaciones, el filtro almacenado se actualiza inmediatamente.

Para conectar en cascada dos o más filtros, resalte los filtros deseados y pulse .Cascade Se agrega un nuevo filtro en cascada al Administrador de filtros.

Para cambiar el nombre de un filtro almacenado, pulse .Rename Aparece el cuadro de diálogo Cambiar nombre de filtro.

Para eliminar un filtro almacenado del Administrador de filtros, pulse .Delete

Para exportar uno o más filtros a FVTool, resalte los filtros y pulse .FVTool

Guardar y abrir sesiones de diseño de filtros

Puede guardar la sesión de diseño del filtro como un archivo MAT y volver a la misma sesión en otro momento.

Seleccione el botón para guardar la sesión como un archivo MAT.Save Session La primera vez que guarde una sesión, se abrirá un explorador Guardar sesión de diseño de filtro, que le pedirá un nombre de sesión.

La extensión se agrega automáticamente a todas las sesiones de diseño de filtro que guarde..fda

Nota

También puede utilizar File > Save Session Y File > Save Session As para guardar una sesión.

Puede cargar sesiones existentes seleccionando el botón oDiseñador de filtrosOpen Session File > Open Session . Se abre un explorador de sesión de diseño de filtro de carga que le permite seleccionar entre las sesiones de diseño de filtro guardadas anteriormente.